[Resolved] Elementor Pro & GeneratePress Full Width Page

Home Forums Support Elementor Pro & GeneratePress Full Width Page

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1184219
    stephen

    Hello,

    I love this theme and have been working with it for a while but I have never been able to get full page width working correctly.

    What I ended up doing was setting all pages to Page Layout – Elementor Canvas which displays the page full width and manually adding the footer and header on each page.

    This was fine when I was working with a handful of pages but its sort of getting out of hand now.

    I’ve set up a test page and posted the URL. The template is from the Elementor Pros library, nothing edited.

    The settings are

    Template Page Layout – Elementor Full Width
    Page Builder Container – Full Width

    I think the issue is something to do with .grid-container but im not a developer

    Thank you for reading

    #1184427
    David
    Staff
    Customer Support

    Hi there,

    can you:

    1. Template Page Layout – set this to Default.
    2. Page Builder Container – Leave this as Full Width.
    3. Disable your cache

    Then let me know so i can take a look.

    #1184433
    stephen

    Thanks for the reply David.

    Page Attribute – Default Template
    Page Builder Container – Full Width
    Cache has been fully disabled.

    #1184513
    David
    Staff
    Customer Support

    In your child theme and in your customizer > additional CSS – you have this:

    .no-sidebar .inside-article > *, .no-sidebar #comments, .no-sidebar .nav-links {
        max-width: 700px;
        margin-left: auto;
        margin-right: auto;
    }

    Remove that

    #1184543
    stephen

    Thanks David.

    Removed the code from both areas and it hasn’t made any changes.

    Any other ideas?

    #1184545
    David
    Staff
    Customer Support

    Now can you check your Elementor sections – they are set to Contained with a Max Width of 1200px. Can you set them to full width ?

    #1184841
    stephen

    Hello David!

    It didn’t work on its own but by adding a “spacer” under the top “hero” and setting it to “stretched” it made everything full-width.

    Thanks for your help. such a great team here at generatepress.

    #1184866
    David
    Staff
    Customer Support

    Glad to hear that 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.