[Resolved] Elementor page/post template not working with generatepress PRO

Home Forums Support Elementor page/post template not working with generatepress PRO

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1161960
    Samuel

    Elementor Pro lets you create page templates that overrides the wordpress theme on specific pages or posts.

    I have created templates for both the homepage and for blog posts, but they do not show up when applied to the site.

    It seems that the Generatepress PRO theme somehow overrides my templates, since it still shows the pages with default settings from the theme customizer. I have tried disabling the blog elements and other things to no avail.

    Others are having the same issue aswell.

    Please help!

    #1161973
    David
    Staff
    Customer Support

    Hi there,

    can you check for plugin conflict by disabling all plugins apart from Elementor and elementor pro – if that resolves the issue then re-enable GP Premium. If the templates ‘break’ again then disable each of the GP Premium modules to see if one of them is conflicting.

    #1161981
    Samuel

    Hi! Thank you so much, David.

    Disabling all plugins solved the problem, and there now seems to be normal functionality, with GP Pro enabled aswell.

    The plugin causing the conflict was JetThemeCore from Crocoblock, an addon to elementor.

    #1161999
    David
    Staff
    Customer Support

    Glad to hear that 🙂
    Trial and error really by re-enabling them one ( or a few ) at a time

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.