[Resolved] Elementor 1.5 (and 1.5.1) not working (buttons not clickable)

Home Forums Support Elementor 1.5 (and 1.5.1) not working (buttons not clickable)

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #341701
    v4ncouver

    Hi,
    I am wondering if anyone is using the latest Elementor 1.5.x upgrade and if yes, is it working?
    I can install/upgrade the plugin fine but upon loading a page to edit it, the buttons (which have a new location) do nothing.
    No matter which one I click, there is no response.

    At first I thought that it might be the GFX pren (Wacom tablet) but even if I use a mouse, nothing happens.

    I can’t google the issue and wonder if it’s the theme or somthing on my end?

    GeneratePress 1.3.48
    GP Premium 1.3.1
    #341708
    David
    Staff
    Customer Support

    There are a few reported issues on the Elementor Facebook Community regarding upgrade issues. Haven’t seen this one – mostly they are WSOD. Most of the problems seem to be related to the memory allocated to WP and/or the PHP. Memory needs to be high (128mb+) and PHP needs to be 7.0.
    This may be something worth checking first. You can find this info on the dashboard > Elementor > System Info.

    Hope this helps

    #341710
    v4ncouver

    Thanks David,
    our server meets/exceeds the requirements.
    I was hoping that today’s update will work but no luck.

    #341732
    David
    Staff
    Customer Support

    Your welcome. It seems there a quite a few random bugs occurring with elementor 1.5. A few people have rolled back to the old version – although the results have not been entirely as expected and then reverted to server backups……
    Just another reason i have decided to park using Elementor for the time being. Might be worth reaching out on the Facebook Elementor Community.

    Good luck

    #341737
    Lyle

    Not having that problem on any of the sites I have updated to 1.5.1 (no issues like that on 1.5 either). All editor buttons are clickable and do what they are supposed to do.

    These sites are all running the latest GP and GPP.

    One site has server specs well below the recommended – purely for testing purposes 🙂

    Have you tried all the usual troubleshooting methods? Switch theme, disable all plugins except E, clear all caches, and more than once, regenerate CSS (Elementor > Tools), etc.

    Cheers!
    Lyle

    http://snifflevalve.com
    Tutorials and tips for GeneratePress, WP Show Posts, WordPress and Elementor

    #341741
    v4ncouver

    Thank you David and Lyle,
    for the time being, I will wait it out because I don’t have time for it and the version which does work is more than adequate for what I need.

    Have a great night (unlike the Premier)!

    #341743
    David
    Staff
    Customer Support

    Your welcome and you too!

    #342650
    v4ncouver

    OK, good news and bad news.

    On my main site https://www.littlecomposers.com the latest version of Elementor 1.5.1 does not work.

    I just installed the Elementor update on https://www.virtualmusicteacher.com which doesn’t use many plugins and it works.
    So the problem most likely is caused by a plugin or custom script that’s needed to make the online learning section work for us.

    If anyone reads this, then please know that the issue is specific to my setup and unfortunatly, I don’t know how to fix it because I need my plugins and customizations more than the latest Elementor upgrade.

    #342740
    Tom
    Lead Developer
    Lead Developer

    Have you asked Elementor support?

    #342915
    v4ncouver

    Hi Tom,
    I would have if Elementor didn’t run on my other WP driven site but since it worked, I knew that the problem is on my end.

    The real problem is this:
    Originally, I bought a WP theme that promised LMS functionality but when all was set up, the page load time was about 5 seconds.
    I pulled the plug and installed Generatepress plus LifterLMS.
    That would have been a great soloution but Lifter didn’t play nice with Generatepress.
    Next, I bought WP-Courseware and by the looks of it, it will be our LMS.

    All of those plugins that have been installed and removed over the last 6 months have probably left a mess in the database.

    If I knew how to just back up the blog posts and images, I’d reinstall a new instance of WP in a heartbeat. Unfortunatly, there isn’t a good way to preserve the images.

    The good news is that little composers now achieves a rating of 100% on pingdom and the load speed is about 1 second for everything.

    Enjoy this amazing weekend! 🙂

    #343032
    v4ncouver

    I have found the cause why Elementor 1.5.x was not working on my site.

    The conflicting plugin is: Remove Query Strings From Static Resources

    As soon as I disabled it, Elementor 1.5.x became usable again. YAY!

    #343166
    Tom
    Lead Developer
    Lead Developer

    Glad you found the solution 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.