[Resolved] display "Your comment is awaiting moderation" on frontend

Home Forums Support [Resolved] display "Your comment is awaiting moderation" on frontend

Home Forums Support display "Your comment is awaiting moderation" on frontend

Viewing 15 posts - 1 through 15 (of 35 total)
  • Author
    Posts
  • #593627
    mehira ganor

    Hi, for some reason, when i comment as complete stranger to a post, the notification “Your comment is awaiting moderation.” is not displaying on frontend.

    this is an example post you can comment to:
    http://www.ganorcpa.com/מסחר-באינטרנט

    GeneratePress 2.1.2
    #593658
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That’s strange – just tested it on our development site and it’s working as it should.

    Perhaps you’re using a plugin or custom function that’s preventing the feature. Anything comment related on the site?

    #594820
    mehira ganor

    there is this plugin installed:
    “Comment Form Validation” by Abhay Yadav
    but after turning it off it still doesnt appear

    #595425
    Tom
    Lead Developer
    Lead Developer

    Can you try deactivating your other plugins one by one to see if there’s another conflict somewhere? When I left a test comment, it just refreshed the page. Did the comment show in your Dashboard?

    #595794
    mehira ganor

    i have just noticed that i have to mark ” save my name and email for…” checkbox in order to make the notification appear.
    all good now.
    resolved.

    #596064
    Tom
    Lead Developer
    Lead Developer

    Ah, that makes sense. Thanks for letting us know! 🙂

    #641998
    jonni

    Hi Tom. I’m having the same problem for the last 24 hours or so, but I don’t have a Comment Validation plugin installed. . Comments are written, they hit the Post Comment button, and they go to the top of the page without the Awaiting Moderation message. My users are confused. The only change I know of is a recent WordPress update. There is no checkbox as mentioned in your conversation with Mahira. I just now enabled the Akismet privacy notification, but it made no change. And I disabled my Comment Images plugin, but it didn’t help so I enabled it again. Any suggestions?

    You can test it at https://www.UltimatePaperMache.com

    Thanks

    #642074
    Tom
    Lead Developer
    Lead Developer

    Hey Jonni,

    You seem to be using some comments-related plugins (uploading images etc..).

    Any chance you can disable those to see if it’s a plugin conflict?

    #642245
    jonni

    I tried, and it didn’t help. Plus, the comment images plugin has been on my site for years and the issue only showed up yesterday.

    #642253
    jonni

    I just found that checkbox that Mehira mentioned. It’s in the Discussion settings. I turned it on, and I do now get the message when it’s clicked, but not when I don’t. This looks like a bug in the system to me. I’ll contact WordPress and see if there’s a way to make it work. Thanks for your help!

    #642575
    Tom
    Lead Developer
    Lead Developer

    This is something WP added to deal with the new GDPR. If you don’t need to comply with those regulations, you should be able to bypass it.

    #642585
    jonni

    Well, you don’t have to enable that feature – but if you don’t you lose your Awaiting Moderation message. You also don’t get the message if someone doesn’t see the checkbox, or chooses to not check it. I switched it off (the Akismet plugin already adds a note under the comment field anyway) and changed my Discussion setting to automatically allow any comment from readers who submitted approved comments in the past. My new readers might be confused, but at least the old ones will have their comments show up immediately and won’t be sent to the top of the page. It’s not a perfect solution. It’s the only one I could think of, though.

    At least now we know what’s causing the loss of that message. Most bloggers don’t manually approve their comments, but I have a blog that gets young readers so I have to be extra careful about what people post.

    Thanks for your time. Enjoy the rest of your day. 🙂

    #642876
    Tom
    Lead Developer
    Lead Developer

    The reason that happens is WordPress needs to set a cookie in order to display that message. However, WP can’t set a cookie without the consent of the user, or else it would break the rules set by the GDPR.

    Glad you found a solution that works for you 🙂

    #845957
    Jodie

    Hi Tom, Leo and David

    I’ve realised that when placing a comment on my sites it also goes to the top of the page with no message to tell the reader that their comment is awaiting moderation.

    I have the checkbox checked in the discussion settings as per below
    Comment author must fill out name and email.

    What am I missing please?

    Could you tell me how I can get the “Your Comment is awaiting moderation” message displayed after a reader has submitted a comment please.

    Cheers Jodie

    #846086
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That message should be added by default. Has the user already been approved before? If so, that message won’t show up.

Viewing 15 posts - 1 through 15 (of 35 total)
  • You must be logged in to reply to this topic.