[Resolved] Display Footer on Blog Page

Home Forums Support [Resolved] Display Footer on Blog Page

Home Forums Support Display Footer on Blog Page

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #671847
    Susan

    Hello – I would like to display my footer widgets on my main blog page. My settings to enable footer widgets is working properly on all pages except the main blog page. Is it possible to enable these widgets on the blog page? Thank you in advance!!

    GP Premium 1.7.2
    #672024
    Leo
    Staff
    Customer Support

    Hi there,

    I assume you are currently using the metabox to set them each page?

    Have you tried using the global setting in the customizer?
    https://docs.generatepress.com/article/footer-widgets/#global-setting

    Let me know ๐Ÿ™‚

    #672567
    Susan

    Thank you. Yes, I am using the metabox on each individual pages to set the footer enable/disable. But my layout does not look like the link above that you referenced in customizer. When I go into “You can find the global setting to set the number of footer widgets in Customize > Layout > Footer”, there is not an option to update the footer widgets (globally) – only the padding, and footer copyright, etc. I enabled the elements feature, I now see a footer bar option, but not a feature to enable individual footer widgets globally. I’m using GeneratePress 2.1.4. Any thoughts? Thanks for any assistance!

    #672614
    Leo
    Staff
    Customer Support

    Hmm that doesn’t sound right.

    So you are not seeing this panel?
    https://www.screencast.com/t/WIJcQyI5gyo

    Can you show me a screenshot of what you are seeing?

    You can upload it to a site like this and provide the direct link here:
    https://postimages.org/

    Thanks!

    #672669
    Susan

    Hello – yes, I see similar panel settings. Here is a screenshot: https://postimg.cc/image/qps58sb4b/
    Thank you for your help!!

    #672671
    Leo
    Staff
    Customer Support

    I can see the Footer Widgets setting in your screenshot.

    It’s the third option and currently set at 2.

    #672685
    Susan

    Hi Leo – thank you, but changing this option to 3 (unless I’m missing something) makes no difference.

    If I navigate to my blog page: https://susanmarksphotography.com/blog/ and scroll to the very bottom of the page, the widgets are not showing – just the more button is showing. And when selecting the more button (and after all posts are loaded) the footer widgets are not showing.

    However, if you navigate to any of my other pages, the footer widgets are there (for example: https://susanmarksphotography.com/about/ )

    Attached is the screen shot for the settings on my blog page:
    https://postimg.cc/image/7fl4pb74r/

    Its just the “main” blog page that the footer widgets do not display. The individual posts however, do show the 3 footer widgets.

    Maybe it is not possible to put the footer widgets on the “main” blog page, but if possible, I would like to do that.

    #672713
    Leo
    Staff
    Customer Support

    Remove this CSS from Additional CSS field in the customizer:

    .blog .footer-widgets,
    .archive .footer-widgets {
        display: none;
    }
    #672803
    Susan

    Whoo hoo – you fixed it! Thank you so much for your support, much appreciated!

    #672828
    Leo
    Staff
    Customer Support
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.