[Support request] Disabling Google Fonts

Home Forums Support Disabling Google Fonts

  • This topic has 2 replies, 2 voices, and was last updated 7 months ago by David.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #1338369

    Sorry to post another thread about disabling Google fonts, but this is doing my head in.

    I’m using the OMGF plugin to host the Google fonts locally. This works great, except for some reason, my site is first loading these fonts locally and then loading them from fonts.gstatic.com adding nearly half a second to my page load time.

    I’ve followed the instructions here https://docs.generatepress.com/article/remove-google-fonts/ and the issue still exists. I’ve added the plugin ‘disable google fonts’ that others have mentioned in their ‘disabling google fonts’ threads and the issues still exists.

    Is there something else I can do to prevent the theme from unnecessarily downloading these fonts?


    This comment is simply so I can subscribe to notifications.

    Customer Support

    Hi there,

    i can see two Fonts being requested from Google:

    1. Barlow – is being called from this inline CSS ID stackable-google-fonts-css – is that the Stackable Plugin?

    2. Roboto – is being requested by ReCaptcha

    That remove google fonts filter only applies to those added to the Theme customizer. You would need to look at those specific plugins to see if they have a ‘local’ option.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.