[Resolved] disabling color of text and background on the edit page

Home Forums Support [Resolved] disabling color of text and background on the edit page

Home Forums Support disabling color of text and background on the edit page

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1588921
    Laura

    Elvin, I have another small problem that I may not be able to do anything about, and is my fault since I made the content background transparent so the dark photo that is the body’s background would show across everything but the side bar.d image photograph. My blog has light text over the dark body photo image, and since my edit page retains the light text and transparent background, I can barely see the text on my edit page. Is there any way to turn off the colors on the edit page, and have regular black print on white background?
    You will have seen what my posts look like from my other question to you on featured images being where they shouldn’t be in the posts, light colored text on a transparent background, against a dark photograph body.
    Thanks again, Elvin.
    Laura

    #1589563
    David
    Staff
    Customer Support

    Hi there,

    in the block editor – click the 3 dot menu in the top right hand corner. Click preferences and then uncheck: Use theme styles

    #1589670
    Laura

    Done. But no change in text color.

    #1589773
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    You can tell GeneratePress not to stylize the editor with this filter:

    add_filter( 'generate_show_block_editor_styles', '__return_false' );

    Adding PHP: https://docs.generatepress.com/article/adding-php/

    Perhaps that’ll do the trick?

    Let us know ๐Ÿ™‚

    #1608606
    Laura

    This css doesn’t seem to be editor-page-text-color-specific, and looks like it might turn off the whole option of having the editor look like the finished product as closely as possible, which is “throwing the baby out with the bathwater”. It’s too important and time-efficient to not have to keep flipping back and forth to see the effects of my changes.
    I’ve sent you a link of an editor page that shows how hard it is to read peach-colored text against a white background. In effect, this eliminates the option to choose a dark background with light text.

    #1609079
    David
    Staff
    Customer Support

    Can you provide a login to the site so we can see the post editor ?

    #1609722
    Laura

    Provide a login? Could you not see the edit page I sent you a link for? Not sure how providing a login is different from sending a link. Anyway, tell me what you need from me. I’m an amateur, sorry.

    #1611254
    Tom
    Lead Developer
    Lead Developer

    Can you try setting your body background in “Customize > Colors > Body”?

    Right now it’s set to white, even though your website has a dark background image.

    If you change the color to a color closer to the background image, the editor will adjust and you’ll be able to see your text better.

    #1611526
    Laura

    My hero!!

    #1612408
    Tom
    Lead Developer
    Lead Developer
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.