[Support request] Disable content title not working

Home Forums Support [Support request] Disable content title not working

Home Forums Support Disable content title not working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1151602
    David

    Hi, I can’t figure out:
    1. where the title “PRODUKTY” in the enclosed picture comes from (Global Header element <h1>{{post_title}}</h1> is “OBCHOD”)
    2. why there is still “OBCHOD” shown even though I disabled the content title of the OBCHOD page. All other pages work correctly, except this one woocommerce shop page.

    https://photos.app.goo.gl/LoAJFDPFiZgkTyT79
    https://photos.app.goo.gl/EwowaGz224DaqJ1L9

    #1151723
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    1. This is coming from one of your Header Elements. You can “draft” them one by one to find the one, or look for one set to “Archives”.

    2. The “Disable Content Title” option won’t work for the archive title here. Instead, go to Customize > Layout > WooCommerce and check the “Disable page title” option.

    #1152345
    David

    Thank you, I resolved Nr. 2., but still have no idea why there is a page_title “PRODUKTY” instead of “OBCHOD”. The element displaying the page_title in the header is set for the entire site.

    #1152351
    Leo
    Staff
    Customer Support

    That’s because it’s an archive page.

    Same thing if you use it on the posts page, it would display the title Blog instead of the page name due to WordPress defaults.

    The workaround is to create a separate header element specific for that page and use a manual title like this:
    <h1>OBCHOD</h1>

    Let me know if this helps 🙂

    #1152374
    David

    I see, but anyway, there must be a code piece, where the “PRODUKTY” comes from, even though it is an archive. Any suggestion?

    #1152425
    Tom
    Lead Developer
    Lead Developer

    It’s likely the Header Element grabbing the name of the Archive (Products).

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.