[Resolved] Disable 'Background Hover' on primary navigation

Home Forums Support Disable 'Background Hover' on primary navigation

  • This topic has 3 replies, 2 voices, and was last updated 6 months ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1198182
    TheSalvadorDaliOfWebsites

    Dear GP team, thanks for a great theme.

    This site is a single-page scrolling affair with top sticky menu: https://www.annakaren.dk

    In the top sticky navigation menu I wish to de-activate the background hover functionality of GP. Right now I set the hover to a blue color. With a WP-plugin called “Page scroll to ID” I have highlighting of menu item currently in viewport enabled. This is seen as a green box cycling the menu items as you scroll the site. This works well, but I want to disable the blue box coming from GeneratePress theme.

    How could I disable background hover to make the menu more simple? It is a menu very few people will actually click, it is more of a progress bar.

    Any advice or alternative solutions are much appreciated,
    Thanks.

    #1198282
    David
    Staff
    Customer Support

    Hi there,

    set the Hover background color to transparent in Customizer > Colors > Primary Navigation.

    Then we can try some very specific CSS to make sure the highlighted menu item colors don’t get overwritten like so:

    .main-navigation .main-nav ul li a.mPS2id-highlight {
        background: #81EA8F;
        color: #331515;
    }
    #1198321
    TheSalvadorDaliOfWebsites

    Hi David,

    Works beautifully. Thanks.

    This theme and support is a winning combination.

    Best wishes,
    The Salvador Dali of Websites

    #1198499
    David
    Staff
    Customer Support
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.