[Resolved] Deleted URLs are getting found by crawlers!

Home Forums Support Deleted URLs are getting found by crawlers!

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1308842
    Ethan

    Hi, I am using the generatepress 2.4.2 and having a weird issue. I was trying to optimise my pages and checked the current redirect and canonical issues to see if I have any. I use both ScreamingFrog and SiteBulb to crawl my site. They both found removed URLs and they say that these URLs return 200. How could this possible?

    I am using SSL ccertificate and all my http urls redirecting to https versions with 307 status code. But then the https versions canonicals to http version back. I changed 1 by 1 with yoast plugin but crawlers still say http versions are canonical urls for the https urls. I really don’t’ know what to do. My site is still hidden from search engines as I am still building it.

    WHat causing this issue and how can I fix this?

    #1308970
    Leo
    Staff
    Customer Support

    Hi there,

    The theme itself doesn’t control this side of things.

    I would recommend checking with your hosting support 🙂

    #1309024
    Ethan

    Hi Leo, I solved the issue. I realized that there were many archive pages. I stopped them and that fixed the issue. But now I am having another one 🙁 all my menu toggle buttons disappeared, they were arrows but now they are small squares. I don’t know what’s causing this issue?

    #1309243
    Leo
    Staff
    Customer Support

    Any chance you can open a new topic and link us to the page in question?

    Thanks!

    #1309785
    Ethan

    I was able to resolve it yesterday, thanks Leo.

    #1310126
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.