[Resolved] Date link not working

Home Forums Support Date link not working

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1234188
    Melanie Jongsma

    When I click on the date link of a post, the link opens only that post. I thought it would generate a list of all the articles posted on that date, similar to how clicking on the author link gives me all articles posted by that author.

    Is there a setting I need to change in Customize? Or did something happen in the most recent GeneratePress update? I’m not even sure what this date link is called or where to find its settings. I appreciate any direction someone can offer!

    Thank you.

    #1234192
    Leo
    Staff
    Customer Support

    Hi there,

    It should work by default and there is no settings to change how it works.

    Any chance you can disable all plugins except GP Premium to eliminate conflicts from other plugins first?

    Let me know 🙂

    #1234272
    Melanie Jongsma

    I disabled all my plugins, even GP Premium eventually, but the date link continued to open the article. I tried several different dates, from the home page as well as within a single article.

    It’s not a feature I use often, so I don’t know when the change happened. I’m using a new ad server, so I thought that might be the conflict, but turning odd that plugin didn’t help.

    #1234293
    Leo
    Staff
    Customer Support

    I’m very sorry – I just actually noticed that the date links to single posts is actually the default behaviour, unlike the author link.

    It is the same in a twenty series WP theme as well.

    In this case, would you want to remove the link instead?
    https://docs.generatepress.com/article/generate_post_date_output/#remove-link-from-date

    Adding PHP: https://docs.generatepress.com/article/adding-php/

    #1234313
    Melanie Jongsma

    Is there a way to change it to collect all the stories on that date? Like a code snippet I could add or something?

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.