Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Resolved] Dashboard page – error lines showing on top

Home Forums Support [Resolved] Dashboard page – error lines showing on top

Home Forums Support Dashboard page – error lines showing on top

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #529631
    jdaco

    After installing the GP Plugin and Theme I got the following Warning lines on top of my Dashboard page, please help, thank you!

    Error messages:

    Warning: shuffle() expects parameter 1 to be array, boolean given in /srv/disk1/2669254/www/mydomain.com/wp-content/plugins/gp-premium/sites/sites.php on line 387

    Warning: Invalid argument supplied for foreach() in /srv/disk1/2669254/www/mydomain.com/wp-content/plugins/gp-premium/sites/sites.php on line 390

    Warning: Cannot modify header information – headers already sent by (output started at /srv/disk1/2669254/www/mydomain.com/wp-content/plugins/gp-premium/sites/sites.php:387) in /srv/disk1/2669254/www/mydomain.com/wp-admin/includes/misc.php on line 1114

    Warning: Cannot modify header information – headers already sent by (output started at /srv/disk1/2669254/www/mydomain.com/wp-content/plugins/gp-premium/sites/sites.php:387) in /srv/disk1/2669254/www/mydomain.com/wp-includes/option.php on line 919

    Warning: Cannot modify header information – headers already sent by (output started at /srv/disk1/2669254/www/mydomain.com/wp-content/plugins/gp-premium/sites/sites.php:387) in /srv/disk1/2669254/www/mydomain.com/wp-includes/option.php on line 920

    #529748
    Tom
    Lead Developer
    Lead Developer

    That’s strange. That means your site wasn’t able to reach our Site Library. I’ll add some hardening to the code to prevent those notices.

    If you refresh the Dashboard a couple times, does it go away? If not, you should contact your host and ask them to make sure your server can connect with gpsites.co.

    Let me know 🙂

    #529884
    jdaco

    Hello Tom, thanks for replying..

    This is weird.. Those error lines appear when I install 1.6 version of your plugin.. I uploaded the 1.5.2.zip file and the error lines didn´t show but then when trying to activate my Premium license key then I get the following error:

    cURL error 7: Failed to connect to generatepress.com port 443: Connection refused

    #529922
    jdaco

    Hello Tom, I contacted the hosting company and they enabled the outgoing connections from their server´s Firewall. Mistery solved!

    Thanks for your support.
    Jorge

    #530128
    Tom
    Lead Developer
    Lead Developer
    #533355
    Jean-Claude

    Hello Tom

    Is it possible to download an earlier version from somewhere?
    I am getting “wp-content/plugins/gp-premium/sites/sites.php on line 338” in v1.6

    #533360
    Tom
    Lead Developer
    Lead Developer

    Our Sites server is currently under DDoS attack. We’re working on a fix.

    Sorry!

    #533380
    David

    Hi Tom,

    Since this morning I’m experiencing the same problem. Something happened in the last 10 hours.

    When I go to
    https://gpsites.co
    I receive this error
    Error establishing a database connection

    But wait a second I tried one more right now and the error is gone and my wp site works fine.

    Thanks,

    David.

    #533382
    Tom
    Lead Developer
    Lead Developer

    If you go to “Appearance > GeneratePress > Site Library” and click “Refresh Sites”, the error should go away now.

    Let me know – sorry for the inconvenience!

    #533429
    Jean-Claude

    Error went by itself, without “Refresh Site”.
    Thank you so much Tom!
    BTW a year ago I took your advise and signed up with SiteGround.
    Couldn’t be happier.

    #533432
    Tom
    Lead Developer
    Lead Developer
    #533870
    Eric

    Hello,
    I am sorry, have a similar problem since I’ve upgraded :

    Warning: shuffle() expects parameter 1 to be array, boolean given in /web/quatrepiliers1/www/wordpress/wp-content/plugins/gp-premium/sites/sites.php on line 387

    Warning: Invalid argument supplied for foreach() in /web/quatrepiliers1/www/wordpress/wp-content/plugins/gp-premium/sites/sites.php on line 390

    I did click on “Refresh Sites”…

    Thanks for your kind answer,

    Veronique

    --
    Eric.

    #533890
    calamityjess

    I have it too, even after refreshing sites.

    And as soon as I posted and did it a 3rd time it worked. THanks!

    #533900
    Tom
    Lead Developer
    Lead Developer

    We’re just setting up some anti-DDoS systems, should be good to go again.

    #533932
    Eric

    Thanks Tom. Good work. Should I go on pushing on Refresh?

    --
    Eric.

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.