Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Resolved] Customizer causes Internal Server Error

Home Forums Support [Resolved] Customizer causes Internal Server Error

Home Forums Support Customizer causes Internal Server Error

  • This topic has 5 replies, 2 voices, and was last updated 3 years ago by Tom.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #556175
    Paul

    Just installed a fresh WP site with latest GP theme plus newest GPP plugin.

    Then I installed ‘Sider’ from the Site library.

    I decided that I want to use page sections, so I enabled that module in GP after the site installation had deactivated it.

    Sections worked just fine on pages.

    But then I went to use the Customizer and that’s generating a Internal Server Error.

    Looking at the link for the Customizer, I see this:

    http://www.example.com/dev/wp-admin/customize.php?return=/dev/wp-admin/widgets.php

    (Yes, this site is currently in the /dev directory while I work on it)

    The ?return=… part in that link looks like its causing this issue. None of the other links in the Dashboard menu have a query string like this.

    I saw another post in the forum that said a corrupted widget was causing the same error when using the customizer, so I removed the Menu Icon widget from the Header widget. That didn’t solve it.

    Any ideas on how to fix?

    Cheers!

    GeneratePress 2.0.2
    GP Premium 1.6.2
    #556184
    Paul

    I decided to deactivate all plugins. That got the Customizer working again. When I went into the Customizer, there was an autosave of my prior changes that hadn’t been saved. So I saved those and then tried reactivating all the plugins that came with Sider. Turns out Menu Icons is the culprit here. Disappointing, considering that it came with the Sider site. Guess I’ll try lightweight social icons instead.

    #556191
    Paul

    Huh. Lightweight Social Icons doesn’t work now.

    Added the LWSI widget to the Header Widget area. Chose my social icons, but wasn’t provided with the field to add the URL to each. Clicked save. Checked home page, nothing there. Went back into the LWSI widget to look for URL fields again, nothing. Not even the social icons I chose earlier were visible.

    #556195
    Tom
    Lead Developer
    Lead Developer

    What’s the actual error you received? It should be one of the most recent ones in your error_log file.

    #556690
    Paul

    Had to set config to enable logging and it seems that there wasn’t enough memory. So I jacked up the memory limit in WP and PHP to 256M (from 64M on this budget host), removed LWSI, reinstalled Menu Icons plugin, and got it working.

    #556900
    Tom
    Lead Developer
    Lead Developer
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.