Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

[Resolved] Customize Fatal error

Home Forums Support [Resolved] Customize Fatal error

Home Forums Support Customize Fatal error

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #215590
    Ricardo

    Hello!
    Sorry for disturbing, but after near a year using GeneratePress Premium (child theme) without a problem, just today I got an error trying to customize: (Searched forums to no avail)

    When I select Appearance -> Customize I got the following errors (the error looks different each time I press “customize”

    Always same error, just on a different line:
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 10880 bytes) in /home/ricardoch1/public_html/wp-content/plugins/types/library/toolset/types/embedded/includes/import-export.php on line 293

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 12800 bytes) in /home/ricardoch1/public_html/wp-content/plugins/types/library/toolset/types/embedded/includes/import-export.php on line 336

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 15360 bytes) in /home/ricardoch1/public_html/wp-content/plugins/types/library/toolset/types/embedded/includes/import-export.php on line 400

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 13440 bytes) in /home/ricardoch1/public_html/wp-content/plugins/types/library/toolset/types/embedded/includes/import-export.php on line 354

    Same error when accesing via the themes page and selecting customize button there.
    Other options as widgets, or menus worked perfectly.
    Far from being an expert, just a medium user.

    (please excuse my English)

    #215591
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The more plugins/features that are used, the more memory your installation uses.

    You’ll need to increase the memory limit: https://generatepress.com/knowledgebase/increasing-memory-limit/

    Hope this helps πŸ™‚

    #215610
    Ricardo

    Solved!!!!
    Magnificent Support, Thanks a lot.
    Kind regards
    Ricardo

    #215611
    Tom
    Lead Developer
    Lead Developer
    #281393
    Laurence Friedmann

    Hi Tom,

    I’ve updated both the wp-config.php and got the admin to increase memory to 256MB, but the error still persists.

    Is there anything else I can try?

    #281452
    Tom
    Lead Developer
    Lead Developer

    Are you getting the same memory error as above? If so, it’s likely your hosting need to up the memory limit for you.

    #281470
    Laurence Friedmann

    Hey Tom,

    I am yes, but the memory limit has already been increased and it doesn’t seem to make a difference. Can an incompatible plugin cause this?

    #281480
    Leo
    Staff
    Customer Support

    Hi Laurence,

    Just want to make sure, have you tried contacting your host to increase the limit for you?

    Let us know.

    #281481
    Laurence Friedmann

    Hi Leo,

    Yes indeed, limit is now at 256MB.

    #281621
    Tom
    Lead Developer
    Lead Developer

    67108864 bytes = 67.11MB.

    Can you confirm that the error is still saying that number of bytes?

    If so, you may need to ask your hosting to look into it, as that’s no where close to 256MB.

    #281683
    Laurence Friedmann

    Hi Tom,

    It is still saying 67108864 bytes, yes.

    We’re using a dedicated server and have a company that manages it for us, but I don’t really know what to ask them to do regarding this. Do you know what could be wrong?

    #281684
    Tom
    Lead Developer
    Lead Developer

    If we’re going to listen to the error, it’s saying that 67MB is over your memory limit.

    You’ll need to ask the management company to look at it – in this case the error is super specific which is good.

    Basically, the way they’ve set the 256MB limit isn’t working, otherwise this error wouldn’t be happening.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.