[Resolved] Customiser issues after switching to GeneratePress

Home Forums Support Customiser issues after switching to GeneratePress

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #309247
    Justin

    Hi – thank you for developing the excellent GeneratePress Premium theme, which I purchased to update my blog.

    I spent a couple of days building out a new version of the blog on my local machine, using MAMP. This was built with a fresh WordPress install and everything worked fine: I was able to see how GeneratePress should work, and to tailor the design as I required.

    This morning I uploaded GeneratePress to my host, and after ensuring WordPress was updated to the latest version – 4.7.4 – and that all of my plugins were up-to-date, I tried switching the theme to GeneratePress.

    Unfortunately there are some curious problems with the Customiser that don’t seem to have been covered in other forum posts. I am able to use some of the features but not others. In brief:

    Site identity, Layout, Colors, Blog, Background Images, Menus, Widgets, Static Front Page all work *but* I cannot change spacing or padding.

    Typography, Copyright and Additional CSS do not work at all. The Save button is simply greyed out.

    Everything seems to work fine outside the Customiser, including complex functionality like the Page Header options at the foot of each page and post editing screen.

    I have tried disabling all of my plugins with the exception of JetPack, on which my site is very dependent (I use the Mosaic Images and Photon features, and also for daily backups). I’m therefore reluctant to disable it.

    So, I don’t know whether the problem could be related to an incompatibility with JetPack. Or whether there is some server limitation preventing the Customiser options listed above from working. I am using Media Temple Shared Hosting. I have adjusted wp-config to set PHP Memory to 128M as suggested in your docs. The only other possibility I can think of is that there might be some residue left from the previous theme – https://theme.wordpress.com/themes/ampersand/ – that is blocking some element of GeneratePress’ functionality. But I’d be surprised as that was a simple blogging theme with relatively limited functionality.

    I’d be very grateful for your advice. I can provide login details if required if you need to take a look.

    Thank you.

    GeneratePress 1.3.46
    GP Premium 1.2.96
    #309302
    Leo
    Staff
    Customer Support

    Hi Justin,

    I don’t think it’s causing by Jetpack.

    So what happens when you change the features that don’t work? do you see it in the preview and it just doesn’t save?

    Are you getting any errors?

    Can you provide a link to your site?

    #309328
    Justin

    Hi Lee,

    Thank you so much for getting back so quickly – didn’t expect it on a Sunday.

    I think I just found the issue: a problematic .htaccess file. I regenerated it thru Permalinks and now the Customizer seems to be working as expected. .htaccess had some lines designed to enhance security that were causing some permissions issues.

    I’ll be in touch if any other problems crop up, but I hope that was the issue. I had tried absolutely everything else.

    #309429
    Leo
    Staff
    Customer Support

    Glad you found the problem.

    We will be here if you run into more trouble 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.