[Resolved] Custom font now showing on mobile

Home Forums Support Custom font now showing on mobile

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #886262
    Paul

    Hi, I have a child theme and…

    In Styles.css

    @font-face {font-family: "Edwardian Script ITC V1";
      src: url("https://domain.com/wp-content/themes/generatepress_child/fonts/ca6f91c0cad2fe33614026d17117601d.eot"); /* IE9*/
      src: url("https://domain.com/wp-content/themes/generatepress_child/fonts/ca6f91c0cad2fe33614026d17117601d.eot?#iefix") format("embedded-opentype"), /* IE6-IE8 */
      url("https://domain.com/wp-content/themes/generatepress_child/fonts/ca6f91c0cad2fe33614026d17117601d.woff2") format("woff2"), /* chrome?firefox */
      url("https://domain.com/wp-content/themes/generatepress_child/fonts/ca6f91c0cad2fe33614026d17117601d.woff") format("woff"), /* chrome?firefox */
      url("https://domain.com/wp-content/themes/generatepress_child/fonts/ca6f91c0cad2fe33614026d17117601d.ttf") format("truetype"), /* chrome?firefox?opera?Safari, Android, iOS 4.2+*/
      url("https://domain.com/wp-content/themes/generatepress_child/fonts/ca6f91c0cad2fe33614026d17117601d.svg#Edwardian Script ITC V1") format("svg"); /* iOS 4.1- */
    }

    In Functions.php

    add_filter( 'generate_typography_default_fonts', function( $fonts ) {
      $fonts[] = 'Edwardian Script ITC V1';
      return $fonts;
    } );

    I selected the font in the customizer, and this works on desktop but not on mobile, see: https://www.screencast.com/t/apoGZSh33

    In mobile mode in the customizer it does load the font there. But when I load the site in Chrome or the Samsung browser on my Samsung S7, the font doesn’t load there. Just some default font there instead.

    Please tell me how to fix this, thanks.

    I already tried to clear cache etc. The basics.

    Also tried fonts that are not custom, and they seem to be working on mobile just fine.

    #886373
    David
    Staff
    Customer Support

    Hi there,

    i tested the site on my iPhone ( as well as in dev tools ) and that header font is being used. Which sort of points the finger at the device cache.

    Not sure why the mobile customizer screen is not displaying it correctly – but it uses Javascript in its output so is not always able to pick up these sorts of changes.

    #886461
    Paul

    I found the issue, was loading the http site instead of https

    #886469
    David
    Staff
    Customer Support

    Glad to hear you got that resolved.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.