[Resolved] cURL error 28

Home Forums Support cURL error 28

  • This topic has 14 replies, 3 voices, and was last updated 10 months ago by Arjun.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #964834
    Mark

    Hi,
    I am getting the cURL error 28 when trying to activate the premium plugin. I have read the other posts but cannot seem to get it working. I contacted my host who said there was no blocks. They basically asked if you could ping my website from your end.

    I have the latest GP / GP Pro installed. GP Pro is the only plugin installed and activated.

    Any help would be appreciated.

    Thanks.

    #965227
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Just to confirm, is this happening when you’re trying to activate your license key?

    We don’t have any IP blocks in place on our end. Just to confirm, can you ask them to make sure your server can communicate with generatepress.com?

    #965608
    Mark

    Yes it happens when I click ‘Save’ to add the license.
    Host has confirmed it can connect to generatepress.com. They have asked if you can run a ping test & traceroute to: 139.99.165.183

    They also wrote:
    I have whitelisted that IP in our firewall but its not going to do anything since we can’t connect to that server.

    I know the block is not on our end and I have tested several other servers on our infrastructure and they are all able to connect to 35.193.232.17 – generate press.

    #966196
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Our host has confirmed that there is no issue communicating with your server.

    Can you get your host to whitelist this IP?: 104.198.56.87

    #966446
    Mark

    I have done that. Their response is below:

    That IP was not blocked in our firewall, I have still gone ahead and whitelisted it.
    If it’s not blocked can they provide testing such as a ping test and traceroute?

    Furthermore here is their traceroute results:

    [root@web13 ~]# ping generatepress.com
    PING generatepress.com (35.193.232.176) 56(84) bytes of data.
    ^C
    — generatepress.com ping statistics —
    6 packets transmitted, 0 received, 100% packet loss, time 5001ms

    [root@web11 ~]# ping generatepress.com
    PING generatepress.com (35.193.232.176) 56(84) bytes of data.
    64 bytes from 176.232.193.35.bc.googleusercontent.com (35.193.232.176): icmp_seq=1 ttl=49 time=274 ms
    64 bytes from 176.232.193.35.bc.googleusercontent.com (35.193.232.176): icmp_seq=2 ttl=49 time=273 ms

    [root@web5 ~]# ping 35.193.232.176
    PING 35.193.232.176 (35.193.232.176) 56(84) bytes of data.
    64 bytes from 35.193.232.176: icmp_seq=1 ttl=49 time=274 ms
    64 bytes from 35.193.232.176: icmp_seq=2 ttl=49 time=273 ms

    #967098
    Tom
    Lead Developer
    Lead Developer

    Here’s our traceroute:

    ping 139.99.165.183
    PING 139.99.165.183 (139.99.165.183) 56(84) bytes of data.
    64 bytes from 139.99.165.183: icmp_seq=1 ttl=47 time=275 ms
    64 bytes from 139.99.165.183: icmp_seq=2 ttl=47 time=273 ms
    64 bytes from 139.99.165.183: icmp_seq=3 ttl=47 time=274 ms
    64 bytes from 139.99.165.183: icmp_seq=4 ttl=47 time=274 ms
    64 bytes from 139.99.165.183: icmp_seq=5 ttl=47 time=273 ms
    64 bytes from 139.99.165.183: icmp_seq=6 ttl=47 time=274 ms
    64 bytes from 139.99.165.183: icmp_seq=7 ttl=47 time=274 ms

    Can you make sure you’re using a somewhat recent version of cURL on your server?

    #967477
    Mark

    Hi Tom. Sorry for the back and forward on this.
    cURL version being used 7.65.1

    So response from the host is as follows:

    That’s a ping test. It seems like his network provider is dropping connections from us as we can’t connect to his server.

    I can’t help out any further Mark as we can’t access his server from ours.

    Looks like I’ll either have to change host or not use GP Pro.

    #967509
    Tom
    Lead Developer
    Lead Developer

    We haven’t received any other reports of connection issues from other users. Who’s your host?

    At worst, you can manually update – it only takes a minute: https://docs.generatepress.com/article/updating-gp-premium/#manually-updating

    At best, we’ll figure this out. However, I have a feeling it’s directly related to your hosting, or our forums would be flooded with similar issues.

    Let me know 🙂

    #967532
    Mark

    My host is https://dreamithost.com.au
    I am based in Australia. This the first time I have used them and was giving them a trial run. The support have been very responsive in trying to help me solve this issue. It does seem they have a reached a point where they feel they can do no more.

    I have never had this issue with GP on any other host that I have used it on. I created another WP install not on a sub domain to test if it was a buggy install but same issue.

    #968019
    Tom
    Lead Developer
    Lead Developer

    Do you have another host you can temporarily try?

    #968415
    Mark

    I do and I can confirm that it works fine. I am sure it’s the host.
    As I am only using it for dev work its no big deal. I can do the manual upgrades.
    Once I deploy to another server, another host for the client, it should fine.

    #968525
    Tom
    Lead Developer
    Lead Developer

    Sounds good – sorry I couldn’t resolve it with the current host.

    #969052
    Mark

    Thanks Tom.
    I appreciate the time you put in trying to solve it.

    UPDATED.
    You wouldn’t believe it. 5 minutes after posting this I tried it again and it worked!
    No idea why this has happened but its great news.

    #969171
    Tom
    Lead Developer
    Lead Developer
    #1084211
    Arjun

    Hey, am facing same error here. When I contacted the host they said nothing to do from their end. What should I do now!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.