Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] cURL error 28: Connection timed out after 10000 milliseconds

Home Forums Support cURL error 28: Connection timed out after 10000 milliseconds

This topic contains 17 replies, has 3 voices, and was last updated by  Tom 2 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #255261

    Hey Tom,

    I have been having trouble updating since I got the premium plugin pack, but since 1.2.91 it has become a real burden. I have the theme and plugin on about 40 sites. About a week ago the server started having painfully long page loads on the backend.

    EVERY link you click inside the admin takes about 40 seconds to load as the server tries to verify the license via cURL. Instead of checking once per day, it checks on every page load.

    My hosting company confirmed this and said:
    The issue is being caused by the gp-premium plugin, its communicating with their API but it appears that their API is offline or unresponsive hence why it takes 40+ seconds to load anything in the backend since its waiting for the API call to timeout before it proceeds.

    I have tried removing the license, saving, and replacing to no avail. This is a real problem with a large number of sites because every click takes forever now.

    HELP

    #255268

    Tom
    Lead Developer

    Hi there,

    That’s very strange – the API talks directly to https://generatepress.com which obviously isn’t unresponsive (we’re on it talking right now).

    I wonder if the IP of your server has somehow triggered something on my server to block it. This server has pretty aggressive security and blocks out any IP it thinks is trying to attack it.

    Can you let me know the IP address of your server so I can take a look? Feel free to use the contact form: https://generatepress.com/contact/

    #255395

    Hi Tom,

    Sure. it’s 199.101.184.254.
    I’m using cloudflare which hides the server IP so yes, maybe that’s causing the issue? All website are on the same server, and all of them are unable to update either the theme or the plugin. I’m dead in the water right now …

    Thanks,
    James

    #255470

    Tom
    Lead Developer

    Any chance you can install the Query Monitor plugin (https://en-ca.wordpress.org/plugins/query-monitor/) and show the results from the HTTP Requests area?

    #255523

    HTTP Request Response
    Call Stack Component
    TimeoutTime
    1 POST
    (Certificate verification disabled: sslverify=false)
    https://generatepress.com/ cURL error 28: Connection timed out after 10000 milliseconds WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    EDD_SL_Plugin_Updater->api_request()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:326
    EDD_SL_Plugin_Updater->check_update()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:98
    apply_filters(‘pre_set_site_transient_update_plugins’)
    wp-includes/plugin.php:235
    set_site_transient()
    wp-includes/option.php:1628
    wp_update_plugins()
    wp-includes/update.php:261
    _maybe_update_plugins()
    wp-includes/update.php:631
    do_action(‘admin_init’)
    wp-includes/plugin.php:524 Plugin: gp-premium 15 10.0044
    2 POST
    https://api.wordpress.org/plugins/update-check/1.1/ 200 OK WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    wp_update_plugins()
    wp-includes/update.php:304
    _maybe_update_plugins()
    wp-includes/update.php:631
    do_action(‘admin_init’)
    wp-includes/plugin.php:524 Core 4 0.3414
    3 POST
    (Certificate verification disabled: sslverify=false)
    https://generatepress.com/ cURL error 28: Connection timed out after 10001 milliseconds WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    EDD_SL_Plugin_Updater->api_request()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:326
    EDD_SL_Plugin_Updater->check_update()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:98
    apply_filters(‘pre_set_site_transient_update_plugins’)
    wp-includes/plugin.php:235
    set_site_transient()
    wp-includes/option.php:1628
    wp_update_plugins()
    wp-includes/update.php:341
    _maybe_update_plugins()
    wp-includes/update.php:631
    do_action(‘admin_init’)
    wp-includes/plugin.php:524 Plugin: gp-premium 15 10.0023
    4 POST
    (Certificate verification disabled: sslverify=false)
    https://generatepress.com/ cURL error 28: Connection timed out after 10001 milliseconds WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    EDD_SL_Plugin_Updater->api_request()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:326
    EDD_SL_Plugin_Updater->check_update()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:98
    apply_filters(‘pre_set_site_transient_update_plugins’)
    wp-includes/plugin.php:235
    set_site_transient()
    wp-includes/option.php:1628
    wp_update_plugins()
    wp-includes/update.php:261
    do_action(‘load-update-core.php’)
    wp-includes/plugin.php:524 Plugin: gp-premium 15 10.0020
    5 POST
    https://api.wordpress.org/plugins/update-check/1.1/ 200 OK WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    wp_update_plugins()
    wp-includes/update.php:304
    do_action(‘load-update-core.php’)
    wp-includes/plugin.php:524 Core 4 0.3375
    6 POST
    (Certificate verification disabled: sslverify=false)
    https://generatepress.com/ cURL error 28: Connection timed out after 10001 milliseconds WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    EDD_SL_Plugin_Updater->api_request()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:326
    EDD_SL_Plugin_Updater->check_update()
    wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:98
    apply_filters(‘pre_set_site_transient_update_plugins’)
    wp-includes/plugin.php:235
    set_site_transient()
    wp-includes/option.php:1628
    wp_update_plugins()
    wp-includes/update.php:341
    do_action(‘load-update-core.php’)
    wp-includes/plugin.php:524 Plugin: gp-premium 15 10.0020
    7 POST
    https://api.wordpress.org/themes/update-check/1.1/ 200 OK WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    wp_update_themes()
    wp-includes/update.php:477
    do_action(‘load-update-core.php’)
    wp-includes/plugin.php:524 Core 3 0.3240
    9 POST
    https://api.wordpress.org/core/version-check/1.7/
    ?version=4.6.1
    &php=5.4.45
    &locale=en_US
    &mysql=5.7.16
    &local_package=
    &blogs=1
    &users=1
    &multisite_enabled=0
    &initial_db_version=36686 200 OK WP_Http->post()
    wp-includes/class-http.php:576
    wp_remote_post()
    wp-includes/http.php:187
    wp_version_check()
    wp-includes/update.php:121 Core 3 0.2610
    41.7129

    #255525

    Tom
    Lead Developer

    Is this your real host IP address, or cloudflares IP address?: 199.101.184.254 – if it’s CF’s, can you send me the actual server IP address?

    You mentioned theme updates not working either? Those are all done through WordPress.org – nothing comes from this server when it comes to theme updates. Can you ask your hosting what PHP version your server is running, and if your curl PHP extension is up to date?

    #255551

    That is the actual IP. The one I use to FTP files.

    #255589

    Tom
    Lead Developer

    Hmm, looked into this and that IP address isn’t banned by my server.

    Can you confirm that theme updates aren’t working as well? That would point to an issue with your WordPress install/server configuration as it has nothing to do with generatepress.com.

    For now what you can do to stop the crazy load times is remove the check for updates completely:

    add_action( 'wp','tu_disable_premium_update_checks' );
    function tu_disable_premium_update_checks() {
        remove_action( 'admin_init', 'generate_premium_updater', 0 );
    }
    #255918

    Hi Tom,

    Sorry for the delay, I had to go out of town.
    I can confirm that 2 unrelated sites were able to update the theme, but the plugin can’t check if there is a newer version so it reports that it is up-to-date when it isn’t.

    I checked several sites that had Version 1.2.89 of the plugin, but were reporting that it is up-to-date. Previously, it would say that the plugin activation code failed (or something similar but it gave an error – not now).

    I’m getting one other error under the Query Monitor Plugin that looks like it is related to the SSL verification:

    Broken Dependencies: wp-auth-check
     /wp-includes/js/wp-auth-check.min.js	
    Error: heartbeat (missing)

    All other errors are https://generatepress.com:

    POST
    (Certificate verification disabled: sslverify=false)
    https://generatepress.com/
    cURL error 28: Connection timed out after 10001 milliseconds	
    
    WP_Http->request()
     wp-includes/class-http.php:223
    WP_Http->post()
     wp-includes/class-http.php:575
    wp_remote_post()
     wp-includes/http.php:187
    EDD_SL_Plugin_Updater->api_request()
     wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:326
    EDD_SL_Plugin_Updater->check_update()
     wp-content/plugins/gp-premium/inc/EDD_SL_Plugin_Updater.php:98
    apply_filters('pre_set_site_transient_update_plugins')
     wp-includes/plugin.php:203
    set_site_transient()
     wp-includes/option.php:1653
    wp_update_plugins()
     wp-includes/update.php:268
    _maybe_update_plugins()
     wp-includes/update.php:659
    do_action('admin_init')
     wp-includes/plugin.php:453

    I tried the code you provided in my functions.php file and it made no difference. However, if I disable the GP Premium plugin the server returns to normal page load times?

    Thanks for your help,
    James

    #255923

    On a side note, this is a dedicated server so I have root access if you’d like me to try something …

    Server Specs might also be helpful:

    OS Ubuntu 16.04.1 LTS
    Kernel version 4.4.0-47-generic

    #255948

    Tom
    Lead Developer

    Just asked my server guy if he has any ideas (he’s way smarter than me). I’ll update when I hear back.

    #256076

    Tom
    Lead Developer

    Ok, I’ve added your server IP to my firewall whitelist. Any change?

    If not, it’s likely something in your server config as it wouldn’t be my firewall and there’s no other reports of issues coming in.

    Let me know – fingers crossed 🙂

    #256166

    YES! I am now able to check for updates, and can see there is a newer version, but it fails to download. The error message is: “Update Failed: Download failed. Unauthorized”

    I believe that also is connected to your firewall.
    My server Admin said:

    Hello James,
    I didn't see any sort of curl errors however there must be some block on his side since any sort of connection is timing out:
    root@fivehappyhounds:/# curl https://generatepress.com
    curl: (7) Failed to connect to generatepress.com port 443: Connection timed out
    root@fivehappyhounds:/#
    root@fivehappyhounds:~# ping generatepress.com
    PING generatepress.com (104.236.212.100) 56(84) bytes of data.
    ^C
    --- generatepress.com ping statistics ---
    6 packets transmitted, 0 received, 100% packet loss, time 4999ms
    root@fivehappyhounds:~# traceroute generatepress.com
    traceroute to generatepress.com (104.236.212.100), 30 hops max, 60 byte packets
    1 192.254.73.105 (192.254.73.105) 0.392 ms 0.464 ms 0.529 ms
    2 172.16.228.14 (172.16.228.14) 0.244 ms 0.286 ms 0.371 ms
    3 dct-cr03--v55.dacentec.com (199.255.156.129) 0.244 ms 0.241 ms 0.237 ms
    4 cha-b1-link.telia.net (62.115.40.229) 2.931 ms 2.930 ms 2.924 ms
    5 ash-bb4-link.telia.net (213.155.132.178) 12.142 ms ash-bb4-link.telia.net (213.155.132.166) 12.118 ms ash-bb3-link.telia.net (62.115.138.42) 9.371 ms
    6 nyk-bb4-link.telia.net (62.115.138.28) 21.045 ms nyk-bb4-link.telia.net (62.115.120.211) 21.193 ms adm-bb3-link.telia.net (62.115.120.18) 15.354 ms
    7 nyk-b3-link.telia.net (80.91.245.82) 15.315 ms nyk-b3-link.telia.net (80.91.248.178) 18.904 ms nyk-b3-link.telia.net (62.115.123.5) 15.870 ms
    8 digitalocean-ic-306498-nyk-b3.c.telia.net (62.115.45.10) 23.009 ms 22.974 ms 22.947 ms
    9 138.197.248.33 (138.197.248.33) 21.055 ms * *
    10 * * *
    11 * * *
    12 * * *
    13 * * *
    14 * * *
    15 * * *
    16 * * *
    17 * * *
    18 * * *
    19 * * *
    20 * * *
    21 * * *
    22 * * *
    23 * * *
    24 * * *
    25 * * *
    26 * * *
    27 * * *
    28 * * *
    29 * * *
    30 * * *
    root@fivehappyhounds:~#
    
    They need to check their firewall to see for any blocks there, if they can't find any blocks a simple way of trying to find out more information about this issue is for them to try pinging and try performing a traceroute from their server to your own server IP of 199.101.184.254 - this should hopefully assist in locating the issue.
    
    As seen with the traceroute above the request leaves your server, it leaves our network and reaches his provider and then times out which would mean there is a IP block on his own VPS

    We are almost there! Thanks for your help.
    James

    #256223

    Tom
    Lead Developer

    Unauthorized is a much easier solution! https://generatepress.com/knowledgebase/trouble-updating/

    Glad we got that figured out 🙂

    #256243

    Removing the activation code, saving, adding it back and saving again did the trick!

    I really appreciate the support. All is working well 🙂
    Merry Christmas!

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.