[Support request] CSS loads on Home page after re-delete of Elementor; is it GP code?

Home Forums Support CSS loads on Home page after re-delete of Elementor; is it GP code?

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1425655
    MC

    Hello, and thank you for your wonderful theme Catalyst, which I love!

    Can you please let me know if this is GP code? My host tech says it’s old Elementor code and has to be removed):

    [lgc_column grid=”33″ tablet_grid=”33″ mobile_grid=”100″ last=”false”]

    Each time I manually delete it throughout my Home page, it repopulates. I’m thinking it might be GP’s special lightweight columns? Please know that I am a simpleton with this; I’m feeling rather code-dependent with this tech, haha. He wants me to use Elementor, and reinstalled it without my knowledge. I deleted it again, because I prefer the lightness and ease of GP — especially since I have a lot of images and don’t want extra weight.

    This all started last week, when there had been a fatal error for Jetpack when I hadn’t been logged in anywhere, and I’d had no auto-updates for plugins. He was logging me back in. I deleted Jetpack, and the Maintenance Mode plugin; previously he had said the MM plugin was the culprit, and that I needed to make a special Maintenance html page with him. But prior to that he said someone had accessed my cPanel. Thing is, it’s only me and I don’t know how to use my cPanel, and I hadn’t been logged in anywhere for weeks.

    If it is indeed GP code, then I can seek a solution elsewhere for restoring my Home page and will stop trying to delete this code, egads.

    Thank you for your assistance. And thanks too for making themes that a neophyte like me could figure out how to use on her own!

    p.s. if it matters, here’s the fatal error data from the WP email:

    WordPress caught an error with one of your plugins, Jetpack by WordPress.com.

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.4.2
    Current theme: GeneratePress (version 2.4.2)
    Current plugin: Jetpack by WordPress.com (version 8.7.1)
    PHP version 7.2.33

    Error Details
    =============
    An error of type E_ERROR was caused in line 14 of the file /home/cocr2304/STARBRIGHT.ONE/wp-content/plugins/jetpack/vendor/autoload_packages.php. Error message: Uncaught Error: Call to undefined function Automattic\Jetpack\Autoloader\jpb636b56969c8ac0707394eb685333a34\set_up_autoloader() in /home/cocr2304/STARBRIGHT.ONE/wp-content/plugins/jetpack/vendor/autoload_packages.php:14
    Stack trace:
    #0 /home/cocr2304/STARBRIGHT.ONE/wp-content/plugins/jetpack/vendor/class-autoloader-handler.php(87): require()
    #1 /home/cocr2304/STARBRIGHT.ONE/wp-content/plugins/jetpack/vendor/autoload_functions.php(92): Automattic\Jetpack\Autoloader\jp706c584b40c416b3678eb907f297053b\Autoloader_Handler->find_latest_autoloader()
    #2 /home/cocr2304/STARBRIGHT.ONE/wp-content/plugins/jetpack/vendor/autoload_functions.php(146): Automattic\Jetpack\Autoloader\jp706c584b40c416b3678eb907f297053b\set_up_autoloader()
    #3 /home/cocr2304/STARBRIGHT.ONE/wp-includes/class-wp-hook.php(287): Automattic\Jetpack\Autoloader\jp706c584b40c416b3678eb907f297053b\reset_maps_after_update(true, Array, Array)
    #4 /home/cocr2304/STARBRIGHT.ONE/wp-includes/plugin.php(206): WP_Hook->apply_filters(true, Array)
    #5 /home/cocr2304/

    #1425766
    Elvin
    Customer Support

    Hi,

    [lgc_column grid=”33″ tablet_grid=”33″ mobile_grid=”100″ last=”false”]

    This is a shortcode used when you have Lightweight Grid Columns plugin installed. https://wordpress.org/plugins/lightweight-grid-columns/

    Can you try disabling all the plugins (especially any caching or server caching) to see if there is anything conflicting?

    Also, can you temporarily disable maintenance mode so we can take a better look at the issue?

    Thank you.

    #1425771
    MC

    Thank you, yes I can disable Maintenance, though the site was being edited before this issue, and it is not yet ready to be online. Hadn’t wanted to do anything more, in case I had to reload from host’s backup. That’s what I had requested, but they chose to resolve by re-activating Elementor, which hadn’t been active for months.

    So please allow me 10 minutes to fix this or that glaring thing, and then you should be able to access. Please do let me know when I can put MM back on. Cuz I have much more to fix before going live again!

    thanks so much!

    #1425774
    Elvin
    Customer Support

    No problem. Take all the time you need.:)

    Please reply to this thread when you disable maintenance mode to let us know.

    Thanks.

    #1425778
    MC

    Thanks Elvin, I disabled all plugins except GP Premium, Lightweight Social Icons, and Lightweight Grid Columns. Deleted browser cache. I had deleted Autoptomize days ago. Still having the same issue.

    MM is now off.

    Please let me know once you’ve had a review and I’ll put MM back on. I truly appreciate your looking!

    Also, just so I’m not misunderstanding, the CSS code I first wrote about is not Elementor, but is GP in origin, yes?, since it comes from Tom’s plugin?

    #1425789
    MC

    My apologies, Elvin, that I don’t know more, but is it okay to enable my plugins again (like mail and form and checkout) or should I wait till after folks have a chance to look at the site?

    #1425790
    Elvin
    Customer Support

    I’ve checked all the pages on your site and didn’t find this.

    Here’s a video of your home page on my end. I don’t see any [lgc_columns] short codes of some sort.
    https://share.getcloudapp.com/ApukvOZ4

    Are you only seeing this on page editor?

    Also, just so I’m not misunderstanding, the CSS code I first wrote about is not Elementor, but is GP in origin, yes?, since it comes from Tom’s plugin?

    It’s a shortcode which shouldn’t be confused with CSS codes. And yes, it is from Lightweight Grid Columns which is one of Tom’s plugins. You don’t have to use it anymore since we now have GenerateBlocks.:)

    #1425791
    Elvin
    Customer Support

    My apologies, Elvin, that I don’t know more, but is it okay to enable my plugins again (like mail and form and checkout) or should I wait till after folks have a chance to look at the site?

    Yes sure, go ahead.:)

    #1425821
    MC

    Thanks Elvin, for the clarification and great support!

    Yes, I’m only seeing the code at the top of this thread on the Home page in edit mode. Here’s what happens.

    Any manner I use to edit the Home page takes me to the Visual Editor screen. But it only has a large gray block under the title HOME title; no content is visible or accessible.

    I was instructed to use Code Editor to go in and delete what I now understand to be non-Elementor short code. That short code is throughout the Home page.

    Then, if I click to exit Code Editor, it takes me to classic mode, which shows me my screen pics and text, but also this line of short code appears throughout. That’s what I was instructed to remove, but cannot. And somehow this seems related (per host tech) to my not being able to access Visual Editor normally.

    I’ve taken screen pics, including the screen pic the tech sent me, but can’t find a way to upload them here, so shall I send to wordpress @ GP email?

    #1425829
    MC

    p.s. It sounds like I should delete Lightweight Grid Columns and install GenerateBlocks? If yes, what would the sequence be to not lose too much of the design and have to re-build Home page?

    #1425834
    Elvin
    Customer Support

    I’ve taken screen pics, including the screen pic the tech sent me, but can’t find a way to upload them here, so shall I send to wordpress @ GP email?

    You can upload the screenshots on any image/file hosting sites (ex. Dropbox, Google Drive) and share the link here.

    p.s. It sounds like I should delete Lightweight Grid Columns and install GenerateBlocks? If yes, what would the sequence be to not lose too much of the design and have to re-build Home page?

    That is actually recommended. Lightweight Grid Columns is fairly dated and GenerateBlocks is basically its successor. In fact, newly made sites that installs Catalyst theme w/ the newest version of GeneratePress from the site library automatically installs GenerateBlocks.

    To be on the safe side, be sure to make a back-up of your site and/or its pages before doing major changes. Ideally, you should be doing this on a staging site so it doesn’t affect the live site.

    #1425860
    MC

    Thanks again. Shared screen pics on Google Drive, sharing via wordpress @ GP email. Or is there a better way? Wasn’t sure if I should broadcast an open link here on this public forum, but can do so if that’s how you can access the photos.

    And yes, I have been attempting to backup but the Updraftplus isn’t creating a directory to Google Drive, and that’s outside of GP’s realm — I’ve got a few things to clear up, ha. Then I’ll set up a subdomain for staging.

    I searched for instructions to switch out LGC for GenerateBlocks. Is there a link somewhere you can guide me to? thanks

    #1425909
    Elvin
    Customer Support

    Thanks again. Shared screen pics on Google Drive, sharing via wordpress @ GP email. Or is there a better way? Wasn’t sure if I should broadcast an open link here on this public forum, but can do so if that’s how you can access the photos.

    You can share the link to the photos here. Just make sure there are no sensitive information. Ex: passwords/username.

    And yes, I have been attempting to backup but the Updraftplus isn’t creating a directory to Google Drive, and that’s outside of GP’s realm — I’ve got a few things to clear up, ha. Then I’ll set up a subdomain for staging.

    Awesome. Let us know when its ready.

    I searched for instructions to switch out LGC for GenerateBlocks. Is there a link somewhere you can guide me to? thanks

    I’m afraid there’s no way to automatically convert LGC contents to Generate Blocks contents. You’ll have to manually rebuild the columns on GenerateBlocks & copy the contents from the LGC contents to it.

    I understand that this may be tedious but you’ll appreciate it the long run since GenerateBlocks is waaaay better than Lightweight Grid Columns, plus it will have less issues in the future since it is actively supported.

    Kindly update us and don’t hesitate to ask if you stumble upon any issues in doing this. 😀

    #1427124
    MC

    Thanks, Elvin, for this wonderful support.

    Here’s the link to the google drive with the screenshots:
    https://drive.google.com/drive/folders/1jItwrITnd70TQYWAtCgSOY2FV30Gc_K1?usp=sharing

    As I was making a new shot, of the blank Home page (no content) in Visual Editor mode, I saw the problem — “Use Blocks” had been toggled on the far lower right of the pic. I’d never used this before, so I was unaware of the effect. I let the host tech know.

    And you can see in his email’s screenshot and in my subsequent version too, that the shortcode for LGC still remains (throughout the Home page). That will go away when I switch over to GenerateBlocks. But at this point, I cannot remember if that coding has always been there in Visual Mode? If not, might it be indicative of a problem, perhaps related to the fatal error at top or to one of the other issues I’ve been having?

    #1427197
    Elvin
    Customer Support

    Hi,

    You can try either:

    Reinstalling Elementor, use it to edit the page to remove the [lgc_column] shortcode from there and save changes, then uninstall Elementor.

    or

    Make sure to uninstall Elementor first, then edit the page using the code editor to remove the [lgc_column] shortcode and save changes.

    or

    Make sure to uninstall Elementor first and attempt block recovery or convert to classic block to remove [lgc_column] shortcode and save changes.

    Note: Regardless if you were able to remove it or not, some editing functionalities might not be recoverable because of its history with Elementor. That said, you may want to consider creating a fresh new page in place of your current homepage to be rid of any issues caused by any previous edits made with Elementor and feel assured that any issues related to it won’t recur. It’s better in the long run.

    When you decide to start fresh with your home page, I highly recommend using GenerateBlocks for doing layouts. It’s awesome.:D

    …If not, might it be indicative of a problem, perhaps related to the fatal error at top or to one of the other issues I’ve been having?

    That error is Jetpack related and should have nothing to do with your page’s content. This is mostly an issue of Elementor adding in the unwanted shortcode. 🙂

    Let us know if this helps.

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.