[Support request] cover image is not visible on blog pages

Home Forums Support cover image is not visible on blog pages

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1395876
    Pulkit Gupta

    I am facing the issue while using GP Premium site-library.

    I have properly uploaded the cover image on the blog and able to see it in the preview image. However, the cover image is not visible on blog pages.

    When I activate any other theme then cover image is properly visible but not in GP Premium. What to do?

    #1395934
    Leo
    Staff
    Customer Support

    Hi there,

    I’m seeing this issue on your site:
    https://www.screencast.com/t/tEm8gLoDy

    Can you fix that first so I can see the cover image issue?

    Thanks 🙂

    #1396374
    Pulkit Gupta

    Hi

    Thanks for your reply.

    Now check

    #1396403
    Leo
    Staff
    Customer Support

    Not quite sure if I understand.

    What cover image are you referring to? Like the featured image?

    If so WordPress doesn’t actually allow a featured image on the main blog page.

    #1396420
    Pulkit Gupta

    Leo

    I am talking about the featured image on the blog page. Refer below screenshot for reference https://www.screencast.com/t/WAzGQ1KQjS

    FYI, when I am using other themes like Hestia it’s perfectly working but not in generate press.

    Let me know how can I fix it.

    #1396816
    David
    Staff
    Customer Support

    Hi there,

    the Dispatch site uses a Header Element to display the Featured Image above the single post content:

    https://docs.generatepress.com/?s=header+element

    The image is added as the background. However it looks like that is not being displayed as your images are being served by JetPacks image CDN. Can you disable this plugin temporarily to check.

    #1396830
    Pulkit Gupta

    Yes, on disable jetpack its working.

    Can you suggest how can i use jetpack while having background images.

    #1396978
    David
    Staff
    Customer Support

    The Header Element is using a URL from the Image CDN – it just looks like it isn’t the correct one or the necessary script it uses to load them is not working as the image is outside of the post content.

    I am not sure it is possible to do that and the alternative would be to disable the Header Element assigned to the Single Posts

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.