Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] Couple Bugs? Page Headers Plugin and Excerpts Not Trimming

Home Forums Support Couple Bugs? Page Headers Plugin and Excerpts Not Trimming

This topic contains 4 replies, has 2 voices, and was last updated by  Tom 2 weeks, 4 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #460628

    Howdy! Love love love all things GP! Thanks for the amazing work. Noticed a couple things that might very well be user errors, but I’ll let you know anyway. I’m on localhost so can’t show anything at the moment…sorry.

    First is the Page Headers plug-in. It’s working a charm on my category pages, but doesn’t show up at all on the Search Results page or with dated archive pages (ie. viewing posts from Month/Year)

    Second is the excerpts feature in Customize > Blog. The excerpts do NOT seem to trim if I use any post format other than standard (as opposed to gallery, aside, etc.).

    Cheers to you guys and a safe Happy New Year to you!

    GeneratePress 2.0.1
    GP Premium 1.5.6
    #460774

    Tom
    Lead Developer

    Hi Charlie,

    Happy New Year!

    1. The Page Header should work on search results as long as it’s set in “Page Headers > Search Results”. Can you confirm that option is set?

    2. Currently we don’t support dated archives – we do have it planned though.

    3. Most post formats display the full content (no excerpts) in order to output the HTML needed (quotes, videos, galleries etc..).

    #461710

    Thanks for the reply, Tom!

    In regards to your questions:

    1. Yes…Page Headers > Search Results is set, but still not showing
    2. Cool…no prob. I’ll jerry-rig something.
    3. Got it. No biggie.

    Just found another issue maybe. I’ve created a page header to show on all single posts and I’m getting a bit fat PHP error window. Here’s what I see at the very top…though there’s a lot more beneath it:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /app/public/wp-content/plugins/gp-premium/page-header/functions/functions.php on line 1117

    Cheers!

    #461718

    Nevermind that last “bug.” I sorted it out.

    #462023

    Tom
    Lead Developer

    1. I just tested this and it all worked out. Can you link me to a search results page?

    What was the issue with the fatal error?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.