[Support request] Conflict with Elementor in 'Blog' and 'Archive' Pages

Home Forums Support [Support request] Conflict with Elementor in 'Blog' and 'Archive' Pages

Home Forums Support Conflict with Elementor in 'Blog' and 'Archive' Pages

  • This topic has 19 replies, 4 voices, and was last updated 3 years ago by Fernando.
Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #535206
    Fernando

    Dear support
    I am dealing with an issue I can’t solve. The situation is next:

    I’ve created a carousel to display a coulple of brands using Elementor where I try to place it in GP footer as widget. This carousel is set up with a full width gray background. The problem I am facing is that carousel does not work and the background does not span full width in the Blog and Archive pages (in rest of pages this works).

    Worth mention this issue dissapers when I deactive the ‘stretch section’ option, but I’d want to get a full width no using a CSS hack.

    Please take at look how it looks at the bottom in the blog and archive pages:

    and this is how it should looks

    I contacted to Elementor support and they told me:

    The issue is indeed between the settings of GeneratePress to modify the footer and the stretch section feature of Elementor. It seems that there is an issue with the hooks and the stretch section feature.

    This has to be investigated thoroughly and it can take some time.

    I reported the issue to the developers so that they can have a look at the issue.

    You should report the issue to the support of GeneratePress as well.

    Could you review this issue from your side If you don’t mind?
    Please, let me know if you need something else from me.
    Best regards

    GeneratePress 2.0.2
    GP Premium 1.6.2
    #535485
    Leo
    Staff
    Customer Support

    Hi there,

    The page you linked is showing a 404 error to me.

    Can you double check?

    Let me know.

    #535503
    Fernando

    Leo, Try with this link

    #535779
    Leo
    Staff
    Customer Support
    #536128
    Fernando

    Hi Leo
    I’ve removed 40px on the left and right padding and this solved the issue with the gap in footer, thanks. However, the main trouble still continues which is the carousel with brands I’ve created with Elementor does not work in Blog and Archive pages.
    Any idea what could be the cause of this conflict?
    Looking forward to your comments
    Best regards

    #536335
    Leo
    Staff
    Customer Support

    There is a console error from Elementor on that page which I believe is causing the issue:
    2018-03-30_0918.png

    I would recommend checking with their support.

    #540638
    dasigna

    sorry for chiming in… having the exact same problem, so being highly interested if theres some news on this.

    in contrary to the TO this works for me even for single blog posts but not at all on any archive type (o.k. not using the native blog page), such as date, category and author …

    the question for me would be: what do the archive pages different than the rest, as it works well on ‘normal’ pages???

    strange enought i sometimes do have a js error too, but not always. and even when theres no js error this will not work as expected.

    any update to this appreciated.

    thanks.

    #541140
    Tom
    Lead Developer
    Lead Developer

    What differs really depends, I would have to see your site.

    On Fernando’s site, the carousel isn’t working because of that JS error. The error looks like it’s having a hard time targeting the element which wants to be stretched to full width.

    What happens if you remove the full width option inside Elementor?

    #541152
    dasigna

    hmmm… strange thing.
    at times i do get the quite exact same js error too. no carousel, nothing special.
    interestingly the js error occurs only from time to time, but no stretch even if theres no error.

    What happens if you remove the full width option inside Elementor?

    … the section (footer) is not stretched at all – on none of the pages, regardless of gp container settings :/

    #541520
    Tom
    Lead Developer
    Lead Developer

    I assume that error (elementor_stretched_section_container) only applies if you have the section set to stretch in Elementor. Are you saying you get that error even without that option selected? That’s something you’ll definitely want to mention to Elementor support.

    #541654
    dasigna

    yes, the error only applies if elementor section is set to (js) stretch.
    no error without.
    but without, the el section in the footer wont stretch at all – on none of the pages. so youre basically stuck at the moment.

    meanwhile elementor support told me that they’re aware of this issue and checking for a fix. so hopefully this will be applied soon. no solution for now – we’ll have to wait …

    so as a conclusion: thats no generatepress error at all ๐Ÿ™‚
    elementor has to fix this.

    thanks for your time.

    #542209
    Tom
    Lead Developer
    Lead Developer

    No problem! Feel free to link me to the page with stretch not applied, and I’ll see if there’s a way for GP to allow it to be full width.

    #542875
    Fernando

    Hi guys
    Sorry for my delayed answer.
    I’ve reported this issue to Elementor’s support and they replied me:

    When you do not use the Stretch section feature the issue does not happen.

    it has been reported to the developer. They will check it and we will update you right after.

    Best Regards

    If you don’t mind, I’d like to leave open this ticket until the issue is solved. We hope this be soon.
    Thanks GP support

    #542886
    dasigna

    @fernando

    sorry to say – but the elementor answer “When you do not use the Stretch section feature the issue does not happen.” is kinda bulls*** answer – cos it wont help at all.
    of course this does not happen when not using this feature – but the section wont stretch at all, on no page. and every feature you cant use the way its expected to is a wasted feature.
    i’ve got the answer from elementor that they are aware of this and will fix it – but without ETA sadly.
    as good as these guys are, lately they seem to be kind of growing a bit too fast and obviously not every new employee can hold the strong pace they go ๐Ÿ™‚
    although, i’m hoping too this will be resolved soon!

    again the question for me is:
    what is different on blog and archive pages so this wont work only there but in all other places. still not able to find out …


    @tom

    if you might have some spare time youre invited to have a look over the site i’m encountering this issue on as you suggested.
    i’ll give you credentials via support-mail as its currently still a dev site.
    but to be honest – dont have much hope you’ll find a way to solve this by gp. worth a try anyway.

    #543488
    Tom
    Lead Developer
    Lead Developer

    What happens when you set the inner footer width to full width in “Customize > Layout > Footer”?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.