Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Support request] Conflict between Generate Press and Elementor Pro

Home Forums Support Conflict between Generate Press and Elementor Pro

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #448030
    Karelle

    I upgraded to Elementor Pro 1.11 yesterday morning and GeneratePress Premium 1.5.6 a few days ago and subsequently, I can’t edit pages in Elementor – I get the error message: The Preview could not be loaded.

    This appears to be a conflict between Elementor Pro and GeneratePress Premium – with either of them turned off the site works correctly, though the layout is screwed. With both on, I get preview errors when trying to edit and get the following error on the front end:
    Fatal error: Uncaught Error: Call to a member function get_class_name() on null in /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor-pro/modules/global-widget/widgets/global-widget.php:122 Stack trace: #0 /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor-pro/modules/global-widget/widgets/global-widget.php(81): ElementorPro\Modules\GlobalWidget\Widgets\Global_Widget->_init_original_element_instance() #1 /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor-pro/modules/global-widget/widgets/global-widget.php(76): ElementorPro\Modules\GlobalWidget\Widgets\Global_Widget->get_original_element_instance() #2 /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor/includes/base/controls-stack.php(1332): ElementorPro\Modules\GlobalWidget\Widgets\Global_Widget->get_controls() #3 /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor/includes/base/controls-stack.php(1415): Elementor\Controls_Stack->_get_parsed_settings() #4 /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor/inc in /home/a4hb/agents4homebuyers.com/wp-content/plugins/elementor-pro/modules/global-widget/widgets/global-widget.php on line 122

    I downgraded Elementor Pro to 1.8.2 and still get the error. I downgraded GP Premium to 1.4.3 and still get the error. So it appears to have been triggered by the upgrade but is not fixable by downgrading.

    What’s especially weird is that the error above seems to refer to the old site that I’m redoing. The correct site (in development) is a4hb.dreamhosters.com.

    So I’m also contacting Elementor support with this same message.

    I tried to attach the system info as a text file but it tells me that .txt is not permitted for security reasons, so the contents of that file follow below:

    // Generated by the Send System Info Plugin //

    Multisite: No

    SITE_URL: http://www.a4hb.dreamhosters.com
    HOME_URL: http://www.a4hb.dreamhosters.com

    WordPress Version: 4.9.1
    Permalink Structure: /%postname%/
    Active Theme: A4HB 0.1

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit

    Platform: Apple
    Browser Name: Firefox
    Browser Version: 57.0
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10.12; rv:57.0) Gecko/201
    00101 Firefox/57.0

    PHP Version: 7.0.24
    MySQL Version: 5.6.34-log
    Web Server Info: Apache

    WordPress Memory Limit: 40MB
    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Upload Max Size: 64M
    PHP Post Max Size: 65M
    PHP Upload Max Filesize: 64M
    PHP Time Limit: 30
    PHP Max Input Vars: 1000
    PHP Arg Separator: &
    PHP Allow URL File Open: Yes
    WP_DEBUG: Disabled

    WP Table Prefix: Length: 10 Status: Acceptable

    Show On Front: page
    Page On Front: Home (#18)
    Page For Posts: Blog: The Boulder Valley Buyer (#20)

    WP Remote Post: wp_remote_post() works

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: On

    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.

    ACTIVE PLUGINS:

    Elementor: 1.8.9
    Elementor Pro: 1.8.2
    GP Premium: 1.5.6
    Send System Info: 1.3

    What to do?

    GeneratePress 2.0
    GP Premium 1.5.6
    #448223
    Tom
    Lead Developer
    Lead Developer

    Those errors all look Elementor related I’m afraid. GP itself doesn’t do anything special to create compatibility with Elementor, so there’s almost zero chance of a conflict created between the two on the GP side of things.

    Hope they get back to you soon with a fix.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.