[Resolved] comment form

Home Forums Support comment form

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #89330
    Karin

    Hi Tom,

    i have a few questions… 🙂 I’m really new to all this…

    First of all, the comment form at each end of a page/post. 1) It doesn’t say that the email address will not be published. I don’t know why and how I can fix that?
    2) At the beginning it says “Kommentar verfassen” (Leave a comment), but I would like to change that and write something else. Is that possible?
    3) I would like to have the option that people, who wrote a comment can check a box so they will get informed, when another comment is written. Do you know any easy plugin that can help me with that? Jetpack doesn’t work with me, when I have installed jetpack, my webpage doesn’t work anymore and goes blank.
    I would like to look it like the comment form on that page:http://www.schwindt-pr.com/2009/04/30/ein-blog-abonnieren-oder-was-ist-rss/

    4) I’ve been searching for so long, but nothing satisfying came up… I would like to have a widget on the right side, where people can subscribe new posts/article. Do you know any easy plugin for that? Again, jetpack would be great but doesn’t work …

    Hope you can help me 🙂

    Regards, karin

    #89542
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    1. This plugin may be helpful: https://wordpress.org/plugins/say-what/

    You can target the email placeholder (Email *) and add your own text.

    2. Same as above – use the plugin to search and replace the text strings.

    3. This plugin should work: https://wordpress.org/plugins/subscribe-to-comments-reloaded/

    4. Give this plugin a try: https://wordpress.org/plugins/wysija-newsletters/

    #91766
    karin

    hi Tom!

    Thank you for your help and your suggestions!
    the mail poet and subscribe plugins work well for me.
    However the say what doesn’t work at all.
    1) My question is how is it possible, that the text
    “email address will not be published” does not exist in the comment form as it is in yours? Is that a wordpress thing or a generate press thing? It usually comes with the text “required fields are marked” and “email will not be published”, right?
    2) My other question is again about the comment form. Since a few days a new text at the bottom of the comment dorm is shown, that “comments are being moderated, so please be patient it can take a while until your comment shows.” Again, is that a wordpress thing or generate press thing and what can I do to either not show it at all, or edit the text myself. In the settings I haven’t changed anything, I mean I have not checked the option that a comment needs to be accepted by the admin.

    Hope you can help me again 🙂

    #91903
    Tom
    Lead Developer
    Lead Developer

    Hi Karen,

    1. I don’t think my comment box has that text either – but maybe it should. It would take up quite a bit of space and wouldn’t look too great, but I’ll try to think of a way to work it in.

    2. This is a WordPress thing, comments are moderated before shown on the website, and that message is shown to the user until the comment is approved.

    #92159
    Karin

    Hi Tom,

    thank you again!

    1) but in your comment form it already says
    Name (required)
    Mail (will not be published) (required)

    and that’s what I’m missing in my website.
    Maybe there is a misunderstanding, I don’t mean contact form, I mean the comment form,
    where I’m writing right now. 🙂

    2) is there a way I can turn that off?

    #92236
    Tom
    Lead Developer
    Lead Developer

    Ah – that’s bbPress functionality.

    Let’s give this PHP snippet a try: https://gist.github.com/generatepress/c72d28622a695ca78f5e

    You can add it using your child theme’s functions.php file or a plugin like this: https://wordpress.org/plugins/code-snippets/

    #94883
    Karin

    thank you!

    that’s almost how I want it…

    Where in my comment php file can I write underneath it says in the comment form Kommentar verfassen (Leave a comment): Deine E-Mail Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert * . So it should look like this:

    Kommentar verfassen
    Deine E-Mail Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

    and then come the fields where to put in name, email etc…..

    Where can I find that in my PHP file and change that? so not directly in the field?

    And at the end of the form it says Comments are being moderated. It can take a while until they show.
    Where can I turn that off or edit that text?

    #94928
    Karin

    finally, I could work it out what I wanted! 🙂 so you can forget my last message…

    So there’S actually just the one thing left.
    At the bottom of the comment form it says “Comments are being moderated. It can take a while until they show.”

    I don’t find that anywhere in the comment php.
    I have NOT checked the box in the settings for discussion, that the comments need to be approved until they show.
    Anti Spam Plugin is deactivated.

    I don’t want that text to be shown at all. How can I do that? Where can I find that?
    Do you have any ideas for me, please?

    #94956
    Tom
    Lead Developer
    Lead Developer

    You may just need to manually approve that one comment in your Dashboard.

    If you aren’t moderating comments, future ones shouldn’t show that message.

    #95004
    Karin

    figured it out now. It has something to do with the WP Super Cache Plugin. This one is responsible somehow for that text shown. Will have to check tomorrow where and how I can change that.

    Thank you for your help!

    #95034
    Tom
    Lead Developer
    Lead Developer
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.