[Resolved] Child Theme Compatibility Issue with Elementor

Home Forums Support Child Theme Compatibility Issue with Elementor

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #525756
    Roverd

    I completely understand the version 2.0 of Elementor and Elementor Pro is still in Beta. Anyway, in the video Ben Pines shared today, he recommends GeneratePress for testing the new features. Right now in my site I’m using a Child Theme to add some Custom Post Types.

    Anyway, I’m trying to create a template for single posts, but when loading the Elementor customizer I’m getting this notification: https://imgur.com/a/sKYo9

    I’ve changed the theme to the default GP and also the TwentySeventeen, and it works in both of them, it’s just the Child Theme.

    GeneratePress 2.0.2
    GP Premium 1.5.6
    #525973
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I’m not sure why 2.0 would have that issue with a child theme. Have you checked with Elementor?

    #526017
    Roverd

    Hi Tom,

    Yes, I have already reported it in the GitHub repository LINK and I’m currently waiting for an answer. I have cleared cache (WordPress, Browser and OS), but the issue remains.

    I’m also wondering why would be a problem with a Child Theme. I’m not adding “crazy” stuff to the functions.php file. Just the necessary code to register the CPT’s.

    #526558
    Tom
    Lead Developer
    Lead Developer

    Let me know if they’re not able to pinpoint it 🙂

    #526666
    Roverd

    Thank you so much for your support Tom. I found a little piece of code that was causing the problem, it was basically a filter to display my CPT’s entries on the categories’ archives. I found that code in an article, and it was the source of the problem. Neither Elementor nor GeneratePress.

    Again thank you so much, now I’m gonna enjoy making some layouts for my custom post types. My site is gonna be solid and fast thanks to GP and it’s gonna look as I want thanks to Elementor.

    #527229
    Tom
    Lead Developer
    Lead Developer

    Awesome, glad you found the issue! 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.