[Support request] Checkout Address Line Two

Home Forums Support Checkout Address Line Two

This topic contains 5 replies, has 3 voices, and was last updated by  David 6 days, 11 hours ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1165658



    I’m getting the following error message at checkout with Square card payments.
    “An error occurred, please try again or try an alternate form of payment.”
    WooCommerce Support have suggested a fix to turn on the “address 2 line” as required.

    WooCommerce Support
    An issue was introduced recently and occurs only when the address 2 line is hidden. As a temporary workaround, you can fix by making this field required in Appearance > Customize > WooCommerce > Checkout

    Only problem is I’ve turned it on under customiser but 2nd line does appear.

    Hope you can help. Our shop maintenance page is on. I can email you a admin login.



    Leo Customer Support

    Hi there,

    Have you checked with WooCommerce’ support for this?

    This doesn’t sound like it’s a theme issue.

    The options in the Customize > WooCommerce panel are actually coming from WooCommerce itself and GP doesn’t control it.

    Let me know if I’m missing something 🙂



    Hi Leo,

    So turning on 2 Line for address isn’t controlled by Generate Press.
    It’s there by default on a new installation.

    Thank you.


    David Customer Support

    Hi there,

    thats correct – if you have Address line 2 field enabled in Customizer > Woocommerce then it should be displayed at the Checkout. Woocommerce is responsible for this function, and GP uses their default templates.

    This means some other plugin or code is interfering with that template.
    Have you tried disabling other plugins / custom functions ?



    Your right there was a plugin effecting it.
    It’s Checkout Field Editor for WooCommerce
    2nd line is working now.
    Thank you


    David Customer Support

    Glad to hear that 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.