Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

[Resolved] Changing font via Customizer Typography is not working.

Home Forums Support [Resolved] Changing font via Customizer Typography is not working.

Home Forums Support Changing font via Customizer Typography is not working.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1047948
    Aaron

    Hi GeneratePress

    We’re facing an issue on our site running GeneratePress & Elementor where our Font isn’t changing, we’ve set it up to “Raleway” via “Customizer” as you can see:

    Raleway Font via Customizer

    However it still shows the “Roboto” font on the website, which is coming from Global.css

    We’ve got this exact same setup on multiple sites and changing the this particular option works on all of the other sites… why not this one?

    Thanks

    #1047963
    David
    Staff
    Customer Support

    Hi there,

    the global.css is the Elementor style sheet. Have you checked Disable Default Fonts in Elementor > Settings ?

    #1047967
    Aaron

    Hi,

    No I have not:

    Thanks

    #1047974
    David
    Staff
    Customer Support

    Try checking it – it will disable Elementors global font css and use the themes instead.

    #1047994
    Aaron

    But all of the other sites haven’t got this option set, yet the Customizer font-setting is working fine for those sites…

    #1047998
    David
    Staff
    Customer Support

    That is peculiar. That Setting is specifically there to disable the global.css style sheet – the CSS within is highly specific to Elementor text elements, so if it is being loaded it should always overwrite the theme settings.

    If i have to use Elementor it is one of the settings i have enabled by default.

    #1048002
    Aaron

    It looks like there is an option in Elementor to setup a custom default font.

    1. Edit any page in Elementor
    2. Click on the Hamburger in the top left
    3. Click on “Default Fonts”
    4. Choose the font you want
    5. Update.

    Is there a hook or something that can be called to check if a custom font has been setup in GeneratePress / Customizer? If there is then I can send a feature request to Elementor to check that hook and then if someone has setup a custom font with GeneratePress it can use that font instead of overriding it.

    If there isn’t a hook, then please can you guys get one added and make the request to Elementor once done.

    #1048029
    David
    Staff
    Customer Support

    Sorry i am little confused.
    Why not just Disable the Elementor Default Fonts then it will respect the Theme settings?

    #1574796
    Dana

    Disabling Elementor Default Fonts did not work for me either. Roboto was still picked up until I updated Elementor fonts.

    #1575050
    David
    Staff
    Customer Support

    Hi Dana, did you resolve the issue ? It seems Elementor has added more complexities with global styles now.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.