[Support request] Changing Color on Button in Nav Menu from Customizer

Home Forums Support [Support request] Changing Color on Button in Nav Menu from Customizer

Home Forums Support Changing Color on Button in Nav Menu from Customizer

  • This topic has 3 replies, 3 voices, and was last updated 3 months ago by Ying.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1969568
    Sarah

    I want to update the button color on a menu item (APPLY NOW on this site below),and while it works with the code we’ve used in the child theme, and will change the color once published from Customizer, it does not reflect immediately like other button colors in the customizer preview. Any suggestions?

    #1969869
    David
    Staff
    Customer Support

    Hi there,

    just to be clear – are you saying the Customizer isn’t displaying the button color you set in your Child Theme? Or does it just take a while to update ? If the latter this may just be the way the Customizer works, as the preview you see has Javascript making changes. Let me know

    #1970044
    Sarah

    Correct, the Customizer doesn’t preview the button color being changed. However, if you hit publish, it does change it. See video: https://www.loom.com/share/3abfb6d8167b4d7688d670262ca1388d

    #1970048
    Ying
    Staff
    Customer Support

    Hi Sarah,

    The button in navigation is not a typical button, it’s a menu item that styled by CSS, so the customizer won’t be able to change its style.

    the Customizer doesn’t preview the button color being changed. However, if you hit publish, it does change it

    This is weird. Can you try change it to another color and clear the cache so we can see how it applies to the front end?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.