[Resolved] Change text "Read more" to button

Home Forums Support Change text "Read more" to button

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • #972671
    An Nguyen

    Hi,

    I want to change “read more” text to button following this guide by using Snippet plugin. I set it “run on front page” or “run everywhere” but it didn’t work. I use theme catalyst.

    Secondly, I want leave comments function like generatepress.com, exactly.( “https://generatepress.com/support/#new-post” ) because I want users reply their codes in “code” tag with an option “Notify me of follow up replies via email” how can I do? I see it simple and beautiful design.

    I used:
    latest version of the theme: 2.3.2
    latest version of GP Premium: 1.8.3

    #973204
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The read more text can be changed using the Blog module in Customize > Layout > Blog.

    Are you wanting to show a list of items the user needs to read before they’re able to leave a comment? We’re using bbPress, and we had to custom code that area with HTML/PHP and Javascript. I would assume it would also be necessary with the standard comments.

    #973220
    An Nguyen

    I found setting in customize. However, if I want this list of items, how can I do? I need the function that user can post their code as a block. Do you know which plugin can do this function?

    Thanks Tom.

    #973490
    Tom
    Lead Developer
    Lead Developer

    Do you have any other examples I can look at?

    #973496
    An Nguyen

    An example you can view here : https://drive.google.com/file/d/1rL7vOhQ58RKlJ-yDOLODKfP3PxsYZvU_/view?usp=sharing

    This allows users to write their codes in a block and also review the block of code before posting.

    #974036
    Tom
    Lead Developer
    Lead Developer

    Something like this might help: https://wordpress.org/plugins/tinymce-comment-field/

    I can’t find anything that will allow the user to preview their comment, unfortunately.

    #974097
    An Nguyen

    Thanks Tom, now I know how to handle it

    Can you help me to display my posts page on (theme catalyst) look like home page theme (sider)?

    #974183
    David
    Staff
    Customer Support

    Hi there,

    you would need to do this:

    1. Customizer > Layout > Container – add some separating space.
    2. Customizer > Layout > Colors > Body – set the background color to contrast the article background color.
    3. Customizer > Layout > Blog > Featured Images under Archives and Uncheck Padding around Image.
    4. Add this CSS:

    .separate-containers .inside-article {
        border: 1px solid;
    }
    #974476
    An Nguyen

    Hi David,

    I could do it by following your guide. However, I face some issues.

    1/ The space between 2 rows of 2×2 columns is big I dont know how to adjust it smaller. The posts in container boxs overlap together.

    2/ The feature images for each post seem to be a bit unequal round 2-3 px (The last two posts’ feature images are not equal). I want all feature images of post have the same size.

    3/ In page, the layout seem to be good except the space between 2 rows of 2x2columns (in issue 1), but when I click on 1 post and go inside. The image background in header disappeared and was replaced by the featureimage of this post. I want to keep the cyan image background of header (below menu) and also disable feature image in post. you can view this layout of the post.

    #974864
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    1. I think this is happening because you’re using masonry along with Jetpacks lazy load feature. Can you try disabling lazy load to see if it fixes the gap?

    2. I’m seeing all of the images using the same size. Did you fix this?

    3. This is being caused by a “Header Element”, which you can find in “Appearance > Elements”. Find the one that applies to “Posts” and remove it.

    #974935
    An Nguyen

    Hi Tom,

    1/ worked like you thought. I fixed it.
    2/ I did manually crop size one by one. Do we have any option for auto resize feature image in a post without do it manually.

    3/ I go appearance> elements there are two : “global header” and “home header”. I cann’t see any option for posts. I tried stick and unstick “Disable Featured Image” on these but not work. I want to keep “pagehero feature image” and disable feature-image of post when users access to a post.

    #975128
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    2. You can find featured image sizing in Customize > Layout > Blog: https://docs.generatepress.com/article/adjusting-the-featured-images/

    3. It should be in the “Global Header” one. You should see a “Background image” option, which you can set to “No background image”.

    Let me know 🙂

    #975129
    An Nguyen

    Hi Tom,
    2. done. however, in masonry mode, feature image of top containner is not full width of the containner, the others are ok.

    3. I changed “No background image” in “Home header” it worked but in “Global Header” can not save because error message “This element needs a location set within the Display Rules tab in order to display”. After change in home header, it still does not work and not display the image background in home page.

    I need this featureimage (in home page) display in a post and not display “featureimage of this post” and display the header title of this post instead of home page title.

    #975131
    Tom
    Lead Developer
    Lead Developer

    2. Ah, this is an issue because you’re featuring the first post, and we don’t have a separate image size option for the featured post (yet).

    For now, you can set different image sizes for the featured post with a filter:

    add_filter( 'generate_blog_image_attributes', function( $atts ) {
        // Set up our conditional
        if ( ! is_singular() && in_array( 'featured-column', get_post_class() ) ) {
            $atts[ 'width' ] = 500;
            $atts[ 'height' ] = 300;
            $atts[ 'crop' ] = true;
        }
    
        // Return our options
        return $atts;
    } );

    3. Does that Element have Display Rules set in the “Display Rules” tab? It should be set to “Entire Site” with “Front Page” as an exclusion: https://screencast.com/t/PzcrWResH

    #975774
    An Nguyen

    HI Tom,

    2/ after adding code into snippet and active at front page. It does not work.

    3/ I found its function and can handle it. Done!

    Your theme is so amazing and full functions I will write a review on my website for that. I want to say thanks for the products!

Viewing 15 posts - 1 through 15 (of 31 total)
  • You must be logged in to reply to this topic.