[Support request] Can't update typography nor other add-ons from customizer

Home Forums Support Can't update typography nor other add-ons from customizer

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #265823
    Neomuk marketing

    Hi there!

    I’m using GeneratePress 1.3.41 and GP Premium 1.2.92 and since some days ago I can’t modify some premium elements from the Customizer.

    For example, I can’t modify typography nor copyright. And when modifying colors I have to save and refresh in order to visualize the changes in the customizer.

    This same problem happens in all the sites I’m using this theme, under WordPress 4.7.1.

    Deactivating all plugins has not helped.

    #265826
    Neomuk marketing

    Some extra information:

    Despite I can modify typography settings, I can’t neither visualize the changes nor save them. If I go to another tab of the customizer, when coming back I see the original settings. Same happens in Copyright.

    However, I’ve tried deactivating the typography add-on and it then let’s me change the body typography as usual.

    In GP settings my license key is correctly set. And I think this is happening since WP 4.7.1 update.

    #265840
    Neomuk marketing

    I’d like to add that I’ve tried downgrading a site to WP 4.7 and WP 4.6.2 as well as GP 1.3.40 in a site with no other plugins activated. And it didn’t work. I think the problem might be in GP Premium plugin but I remember 1.3.92 working correctly.

    #265844
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Using Chrome, right click in the Customizer area and click “Inspect”.

    Open the “Console” tab, and then try making a change in the Customizer. Any red errors come up?

    #265848
    Neomuk marketing

    Hi there Tom!

    Thanks for your reply.

    However, I remembered that my hosting (Siteground) made some changes into my htaccess recently in order to stop some bot attacks I was getting. So I tried to see where the problem was and it seems I found it.

    It’s all working perfectly since I deleted

    # Block Emtpy and Spoofed User-Agents #
    RewriteCond %{HTTP_USER_AGENT} ^-?$
    RewriteRule .* – [F]
    # Block Requests with Empty Accept-Encoding #
    #RewriteCond %{HTTP:Accept-Encoding} =””
    #RewriteRule .* – [F]
    # Block Request Method #
    RewriteCond %{REQUEST_METHOD} ^(connect|debug|delete|move|options|put|trace|track) [NC]
    RewriteRule .* – [F]
    # Block Referrers #
    RewriteCond %{HTTP_REFERER} ([a-z0-9]{2000}) [NC,OR]
    RewriteCond %{HTTP_REFERER} (semalt.com|todaperfeita) [NC]
    RewriteRule .* – [F]
    # Block Double Slash
    RedirectMatch 403 \/\/
    # Block Bad Query Strings #
    RewriteCond %{QUERY_STRING} ftp\: [NC,OR]
    RewriteCond %{QUERY_STRING} http\: [NC,OR]
    RewriteCond %{QUERY_STRING} https\: [NC]
    RewriteRule .* – [F]
    # Block Proxy Requests #
    RewriteCond %{HTTP:VIA} !^$ [OR]
    RewriteCond %{HTTP:FORWARDED} !^$ [OR]
    RewriteCond %{HTTP:USERAGENT_VIA} !^$ [OR]
    RewriteCond %{HTTP:X_FORWARDED_FOR} !^$ [OR]
    RewriteCond %{HTTP:PROXY_CONNECTION} !^$ [OR]
    RewriteCond %{HTTP:XPROXY_CONNECTION} !^$ [OR]
    RewriteCond %{HTTP:HTTP_PC_REMOTE_ADDR} !^$ [OR]
    RewriteCond %{HTTP:HTTP_CLIENT_IP} !^$
    RewriteRule .* – [F]
    # Bot Block End #

    but I have no idea why is this interfering with some Premium add-ons…

    #265938
    Tom
    Lead Developer
    Lead Developer

    I’m not sure, you would have to check the console log as I mentioned above for any specific errors being caused by that code.

    The Customizer is driven by javascript, so maybe something in there is blocking it/breaking it. Not sure.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.