[Resolved] Can’t remove date from URL

Home Forums Support Can’t remove date from URL

  • This topic has 10 replies, 4 voices, and was last updated 1 month ago by Leo.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1621952
    Roey

    Hi,
    Every time I try to change the permalink from month and name to post name, the URL work, but the blog post is not functioning
    I’m working with Vinyasa theme
    Instead of displaying the post it shows me the headline and short text. If I click it, it will return to the same page. Really weird bug, or something that I missing?
    I always remove the dates from URL and have never had any issues with other themes
    screenshot
    When I change the permalink back to date, it looks normal again

    #1622027
    Bryan

    Assuming you’re using one, have you tried clearing your cache after making the change?

    #1622215
    David
    Staff
    Customer Support

    Hi there,

    did you correct the issue ? If i visit your site and follow the link in your top menu it displays the single post – not the Blog ( as per the image you provided ).

    #1624155
    Roey

    Hi,
    1. Yes, of course, I cleaned the cache
    2. David, to your question, I reverted it back to the dates format. That’s why now it is OK
    This is how it looks like when there are no issues (with the dates format):

    https://ibb.co/8b5VQ61

    The post is also marked as post format
    However, after I change again the permalink to post name, that’s how it looks like right now:
    https://comparativapatineteselectricos.es/mejores-patinetes-electricos-cual-comprar/
    (same to the first screenshot I sent)

    #1624619
    David
    Staff
    Customer Support

    Do you have any redirect plugins ?
    If not can you share a screen shot of the permalink settings ?

    #1625168
    Roey

    No David, I don’t have any redirect plugin that I’m aware of
    The only additional plugin I installed is Yoast, which has nothing to do with it
    You can see the screenshot here:
    https://ibb.co/DQbPYBD

    Please let me know in case you need access the login details privately

    Thanks,

    #1625392
    Leo
    Staff
    Customer Support

    The theme itself should not interfere with the permalink structure at all as it’s handled by WordPress completely.

    Does the same issue occur if you activate a Twenty series WP theme to test?

    #1627071
    Roey

    I would like to avoid using other themes from the site library as it will delete all what I’ve done so far:
    According to this – Existing Site Import Detected
    It is highly recommended that you remove the last site you imported before importing a new one.

    This process restores your previous options, widgets and active plugins. It will also remove your imported content and CSS.

    Is there any other way I can resolve this? I’m willing to provide credentials if necessary

    Thanks,

    #1627079
    Leo
    Staff
    Customer Support

    I’m not asking you to remove the current template – I’m asking you to activate a Twenty series WP theme like Twenty Twenty-one from Appearance > Themes to confirm that the issue still exists.

    The theme itself should not interfere with the permalink functions from WordPress so let’s try activating a standard theme from WP to make sure this is indeed the case.

    Let me know if this explains it.

    You won’t lose anything when you deactivate GP and activate it back again.

    #1628157
    Roey

    Thanks
    I just resolved the issue – changed the URL of the blog post, and that’s it!

    #1628267
    Leo
    Staff
    Customer Support
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.