[Support request] Can’t remove a featured image

Home Forums Support [Support request] Can’t remove a featured image

Home Forums Support Can’t remove a featured image

  • This topic has 7 replies, 4 voices, and was last updated 1 month ago by Ying.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2245781
    Nick

    Hi,

    I can’t remove a featured image on a blogpost, the page see below . How can I fix this?

    #2245804
    Fernando
    Customer Support

    Hi Nick,

    If you enable “Disable Elements” module in Appearance > GeneratePress, you’ll have an option to disable the feature image while editing a post: https://share.getcloudapp.com/DOudvW46

    You may also do so with a Layout Element if you want to remove the featured image for all posts, or more than one posts.

    Reference: https://docs.generatepress.com/article/layout-element-overview/#disable-element

    Hope this helps!

    #2273372
    Prabakaran

    Hello,

    I used this option to disable the featured image for the page. I disabled the display option for the featured image, but it loads the featured image in the frontend. I do not want to load the image in the frontend. for ex. please look at it https://nviewscareer.com/

    #2273381
    Fernando
    Customer Support

    Hi Prabakaran,

    Can you provide the link to the specific page with the specific issue?

    If you’re seeing the featured image in the homepage, kindly let us know.

    Hope to hear from you soon.

    #2273435
    Prabakaran

    Hi, please have a look at the frontend https://nviewscareer.com.
    Indeed, the image is not displayed in the frontend, but the featured image is loaded in the html as < div class=”featured-image page-header-image “> < /div >. Also, the external stylesheet featured-images.css is loaded as well.
    For your information, I do not use a page header element (hero). Only the page content.
    < div class=”featured-image page-header-image “>
    < img width=”800″ height=”450″ src=”/scaled-800×450.jpg” alt=”nViews Career Academic Job Board” / >

    #2273472
    Fernando
    Customer Support

    I see. Thank you for clarifying.

    That’s the default if you have a Featured image set in the Page Settings of a page.

    Example: https://share.getcloudapp.com/JruoObkd

    You can disable Page Images through Appearance > Customize > Layout > Blog > Featured Images > Pages: https://share.getcloudapp.com/L1uXR7ON

    Hope this clarifies!

    #2273594
    Prabakaran

    Hi, thanks for the update and the information.
    The settings mentioned applied to all pages. Then we lost the granular control on some pages.
    Please consider updating the disable items feature to increase productivity.

    Could you please let me know the exact filter to dequeue the featured-images.css in custom post types.
    Since I am using a unique layout, featured-images.css is completely unused.

    #2274022
    Ying
    Staff
    Customer Support

    Please consider updating the disable items feature to increase productivity.

    That’s actually a bug. When you use the disable element of layout metabox in the post/page editor, it is supposed to remove the image from HTML, we’re aware of that issue, and will try to fix it ASAP.

    For now, the layout element is a better choice, as it removes the image from HTML.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.