Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Can't get blog images to post on the home page.

Home Forums Support Can't get blog images to post on the home page.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6186
    Scott Alan Buss

    Hello All,

    I hope that this note finds you well.

    I just got the add-ons installed and have been enjoying them quite a bit already.

    That said, I am having trouble getting images to work properly with blog posts.

    Each post leads with an image (usually a .jpg of around 450×450 pixels in size), but none of them will show up on the main/home blog page. I have checked the settings in the new Generate Blog add-on to be sure that the images are set to “on”, so to speak, and these images have pulled onto my home page before without any trouble, but now I just can’t get them to show. (They do come up just fine once a specific blog entry is clicked on, by the way.)

    Any help that you can offer would be much appreciated.

    Thanks and have a good one!

    Best,

    Scott

    #6187
    Tom
    Lead Developer
    Lead Developer

    Hi Scott,

    Are you setting the post image using the Page Header addon?

    If so, it won’t serve as a post image on the blog page as of right now. I left that functionality for the “Featured Image”.

    However, I’m releasing a new version of Page Header today that will show it on the blog post index if no featured image has been set.

    I want to keep both of them going so you can have one image on the blog post index and a different one on the single post page.

    However, the desired functionality would be to use the page header if no featured image has been set.

    So for now, you can set the Featured Image as well as the page header to make it show up on the blog index.

    Let me know if you have any more questions 🙂
    Tom

    #6188
    Scott Alan Buss

    Howdy Tom,

    Thanks for the speedy reply!

    Whenever I have a “featured image” set, it loads just fine onto the blog home/index, but once the specific post is selected, its page loads with a huge version of that featured image at the top.

    Originally, I had been just putting the images in the main body of the blog at the beginning and that had worked fine. Right now I am only able to get blog post images to show on the home page/index when they are the “featured image”, but then I get the giant image atop the blog-specific page.

    Sounds like I might benefit from that new version of Page Header today, but I am definitely open to other ideas, too.

    Overall, I am really enjoying the add-ons so far.

    Thanks again for your quick help and for all of the work that you are doing.

    Have a good one!

    Best,

    Scott

    #6189
    Tom
    Lead Developer
    Lead Developer

    Hi Scott,

    Ah – I see.

    Couple options.

    1. You can choose for the image to appear within the content container so it’s not so huge by going to Customize > Layout > Single Post Header Position.

    2. You can hide the large image on single post with some simple CSS:

    .page-header-image-single {display:none;}

    You can add that in by using a child theme or a custom css plugin like this: https://wordpress.org/plugins/simple-css/

    Hope this helps! 🙂
    Tom

    #6192
    Scott Alan Buss

    Howdy again Tom,

    I’m sure that it’s probably something I’m missing, but I tried both of those solutions (after installing the Custom CSS plugin you suggested – thanks!) and am still getting the same result.

    Can you post or send me a link to the new Page Header version when it is available today? That might save both of us some trouble. 🙂

    I will give that a shot when it’s available unless you have any other suggestions.

    Thanks again for your time, work, and patience!

    Best,

    Scott

    #6193
    Tom
    Lead Developer
    Lead Developer

    Hi Scott,

    That’s odd – that code should definitely remove the large image from your single post page.

    Can you link me to the page in question, either in here or to support@generatepress.com?

    Once I release the new version it will show up in your Dashboard saying it’s ready for an update 🙂

    Either way we’ll get this fixed for you!

    #6195
    Scott Alan Buss

    Thanks, Tom!

    I just emailed you the link.

    One way or another, I’m sure it’ll work out.

    I will be away from the PC for the next 2-3 of hours, but will check in sometime after that.

    Thanks again for your super speedy help!

    Best,

    Scott

    #6196
    Tom
    Lead Developer
    Lead Developer

    Interesting – will have to look into why it did this, but the class name isn’t detecting the single post page.

    This CSS will work for you:

    .single .page-header-image {display:none;}

    Thanks!

    #6375
    Scott Alan Buss

    Thanks, Tom!

    The second CSS worked, but when after today’s update was installed, the same problem re-surfaced. I was able to use the first CSS that you gave me to fix it again, though, so I’m good to go on this issue.

    Thanks again for your help!

    Best,

    Scott

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.