[Support request] Can’t achieve green CWV on mobile with Ezoic; FCP taking too long

Home Forums Support [Support request] Can’t achieve green CWV on mobile with Ezoic; FCP taking too long

Home Forums Support Can’t achieve green CWV on mobile with Ezoic; FCP taking too long

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2237320
    Richard

    Hi there,

    Love GeneratePress and switching to it has sped up my site a lot.

    However, I still can’t get green CWVs on mobile despite most pages easily passing on desktop.

    I am having trouble diagnosing what the true cause is. I am running Ezoic (with LEAP cache and optimisation engaged), so obviously there are ads on the pages. However, even the ad-free pages are still failing on mobile.

    I can supply URLs – I just to see if there is something obvious I am missing to reduce delays on mobile? Possibly it is occurring because Ezoic is lazy loading the feature image, but I am not sure how I can turn that off without affecting other images.

    Rick

    #2237335
    Leo
    Staff
    Customer Support

    Hi Rick,

    Have you checked with Ezoic support team on this before?

    I would say that Ezoic doesn’t have the best reputation from what I’ve seen.

    #2237346
    Richard

    Hi Leo,

    Yes, I am checking this one with them concurrently. However, I am not meeting LCP/FCP even on pages that have no ads, so I am trying to get to the root cause of it.

    Rick

    #2237377
    Fernando
    Customer Support

    Hi Richard,

    Optimization plugins sometimes cause loading issues, which in turns affects LCP.

    Specifically, sometimes above the fold images are lazy loaded as well which shouldn’t be.

    As a first line of debugging, we usually advice doing #1 here starting with all caching/optimization plugins: https://docs.generatepress.com/article/debugging-tips/

    Through this, we’ll see if a setting in you optimization/caching plugin is indeed causing this.

    It would also be good to take a backup of your website before doing this.

    Can you also provide the link to the site in question?

    You may use the private information field for this: https://docs.generatepress.com/article/using-the-premium-support-forum/#private-information

    Kindly let us know how it goes.

    #2237394
    Richard
    #2237405
    Fernando
    Customer Support

    Thank you for attaching the link to the site.

    Looking at the page, I can still see Ezoic active.

    It would be best to preload/preload and use critical CSS for above the fold assets and other critical stuff only. Preloading/preconnecting a bunch of other stuff may cause issues negating its purpose.

    Avoid Lazy loading as well for above the fold assets. For instance, I can see that your logo is being lazily loaded by Ezoic.

    Perhaps you can try testing the CWV scores of your site with Ezoic disable, and also reach out to Ezoic for the best settings to improve your mobile CWV scores.

    Hope this clarifies!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.