[Support request] Cannot change main logo

Home Forums Support Cannot change main logo

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1108060
    Michael

    I’ve just purchased GP and was after installing Peak from Site Library I was able to change the main logo. However when I went back to update it with another logo file it won’t change.

    I get to Media, upload a new file, all seeming normal, but it never saves. It is stuck on the first logo I inserted. I’ve cleared cache, all plugins are off except GP. Working in Chrome, so opened the site in Safari and went through the motions, same result.

    WP memory is set to 256MB, PHP 7.2, GPPremium plugin and theme up-to-date, WP 5.3.1.

    Any help is much appreciated because this is unusable as is.

    #1108075
    Leo
    Staff
    Customer Support

    Hi there,

    Currently I’m only seeing the site title and no logo image:
    https://www.screencast.com/t/BM1q4p2i1Ae

    Is that not what you are seeing?

    #1108088
    Michael

    Hi there Leo,
    Sorry, I’d just cleared the logo trying to test things. I’ve inserted a test logo and you’ll see the one displaying is that first one I inserted that has no star icon.
    https://ibb.co/L5cCgb8

    #1108100
    Leo
    Staff
    Customer Support

    I’m still just seeing the site title on my end.

    Sounds like a caching issue though.

    Can you disable all plugins except GP Premium and make sure there is no server cache activated?

    #1108103
    Michael

    Try again – and can confirm all plugins except GP Prem. disabled.

    #1108120
    Leo
    Staff
    Customer Support

    Hmm I’m seeing the logo without the star.

    Are you using a child theme by any chance?

    #1108129
    Michael

    No child theme.

    #1108132
    Leo
    Staff
    Customer Support

    Can you make sure the changes are indeed published and not save as draft?
    https://www.screencast.com/t/qgJPL1agY0x

    If that doesn’t help then can you check with your hosting support to see if they can identify any issues or maybe some sort of hard server caching?

    We know that the option is working for sure.

    #1108197
    Michael

    In the theme customizer there is only Publish not Draft. So yes, it’s definitely published.
    I’ve just tried to replace the logo again with the original Peak template “peak.png” logo.
    – Click “remove logo”, logo removed (and can see that in a published page).
    – Replace logo, publish. Published page has the “Your logo” as before.
    https://ibb.co/nCCYK93

    * I installed twenty seventeen theme and its doing the same thing – the “your logo” image appears no matter what file you choose.

    I’ve never encountered this on any WordPress site hosted on this same shared hosting.

    The hosting support for this particular site is abysmal, taking days to respond – no point me even trying to contact them. I need to sort it out myself. I have cPanel access.

    Anything I can still check?

    #1108203
    Leo
    Staff
    Customer Support

    You need to click the gear icon beside publish in the customizer to see the extra options I’ve shown here:
    https://www.screencast.com/t/qgJPL1agY0x

    I also assume it’s published though.

    What if you simply remove the original logo from the media library?

    Unfortunately I really don’t have any other ideas.

    #1108214
    Michael

    Yes, definitely published.
    I removed that file it keeps inserting, from Media, and now it just shows nothing – I’ve tried inserting a few logo files, still nothing.

    I’ll try to keep investigating but if I can’t get it to work I might need to return the product for a refund. I’ll keep you posted. Thanks for your help.

    #1108222
    Leo
    Staff
    Customer Support

    Let me know what you find out.

    Your hosting support is your best bet unfortunately.

    We are happy to provide the refund as well if you need – just request it through Account Issues here:
    https://generatepress.com/contact/

    Hope you are able to find a solution though!

    #1108223
    Michael

    Thank you for the super quick responses Leo. Much appreciated. I’ll keep you posted.

    #1108281
    Leo
    Staff
    Customer Support
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.