[Resolved] Bug on the GeneratePress template?

Home Forums Support Bug on the GeneratePress template?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #81908
    Vhin

    Hello,

    I have found your template awesome and easy to use. I am new into WordPress and planning to use your template on my website that I will create in the future. I tried to learn how to customize your theme but there is this kind of bug I encountered when trying to play around with the ‘not found page’ results. When I try to do search on website and returns no results it will display the 404 page normally with the setting I set in sidebars and footers like when you try this ‘http://generatepress.com/?s=missing+page’ but when you try putting random url pattern like this ‘http://generatepress.com/missingpage’ the sidebar will be gone but the footer will stay which I guess is OK. But when you try to put any random url with ‘.xml’ extension like ‘**’, the template will show the default theme sidebar and footer which I think is not good, can be unsafe and destroys the website looks.

    Regards,

    Vhin

    #81910
    Tom
    Lead Developer
    Lead Developer

    Hi Vhin,

    1. http://generatepress.com/?s=missing+page – this URL will be seen as a blog page by WP, which means it will take on your blog layout setting.

    2. http://generatepress.com/missingpage – this URL is seen as a page, so it will take on your page layout setting.

    3. As for the 3rd URL – this is super weird – thanks for pointing it out. I’m not experiencing it while testing on my development site, so I’m thinking it’s a bug in a plugin I have installed on this site – will investigate. Let me know if you experience this while developing your own site 🙂

    Thanks!

    #81977
    Tom
    Lead Developer
    Lead Developer

    Figured it out – this is a WordPress SEO by Yoast bug.

    I’ve contacted them to get it fixed.

    Thanks!

    #82054
    Vhin

    Hello again,

    Yes I did also installed bunch of plugins just to learn ‘how this works’ kind of stuff. And yeah I think one of those was the Yoast thing, but I have yet to confirm it because I am not at home as of this moment. But for now I also wanted to include that the weird plugin bug not only replaces/removes the sidebar and footer widgets but also the header/navigation widgets like in your site’s case, it removes the twitter and facebook icons beside the cart icon on your navigation.

    #82080
    Tom
    Lead Developer
    Lead Developer

    Yea, it’s a bug in WordPress SEO. If you land on a 404 that ends in .xml (good thing this barely every happens – not even sure how you stumbled upon it?) – it won’t recognize any widgets.

    Hopefully they fix it soon 🙂

    Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.