[Support request] Blog theme download for Open Live Writer failing in GP Premium

Home Forums Support [Support request] Blog theme download for Open Live Writer failing in GP Premium

Home Forums Support Blog theme download for Open Live Writer failing in GP Premium

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #2326075

    I am trying to configure “Open Live Writer” for my blog. My active theme is gp-premium-2.1.2. When Open Live writer tries to download blog theme for offline editing, it is failing.
    Error pops up after a few minutes.
    “Blog theme couldn’t not be downloaded”
    “You will be able to post to this blog, but you won’t able to see blog theme while editing blog post”

    Please fix the theme error. Open live Writer is de facto offline blog editing software for WordPress.
    Thank you.

    Customer Support

    Hi there,

    I am not sure what GP has to do here to be compatible with what is a 3rd party API.
    Do you have any more information on this ?


    I did try with a wordpress.com, blog. And this functionality works. Open Live Writer uses XMLRPC protocol for the live preview.
    Following link says, why this is failing.

    Error with Template Detection: Windows Live writer cannot download your custom WordPress theme for a live preview.
    Solution: You need to make sure that the following snippet is present in your WordPress theme (You can look for this code in between the <head> tags)
    <link rel="EditURI" type="application/rsd+xml
    "title="RSD" href="http://www.YourBlog.com/xmlrpc.php?rsd" />

    My question is in GeneratePress which theme file needs to be modified?
    Please Enlighten. Do I make sense?

    Customer Support

    So, if you just need the EditURI rel tag in the <head> then:

    1. In Appearance > GeneratePress – Activate the Elements module.
    2. In Appearance > Elements, create a new Hook Element.
    2.1 It the Hook text area add your link:

    <link rel="EditURI" type="application/rsd+xml "title="RSD" href="http://www.YourBlog.com/xmlrpc.php?rsd" />

    Update the href to match your site URL to the relevant xmlrpc file.

    2.2 Set the Hook to wp_head

    2.3 Set the Display Rules > Location to Entire Site

    2.4 Publish the Hook.


    Thank you, David. It still didn’t work. Please escalate the issue with your developers team. My website is chill.vc, the code that you suggested to add, can be seen in “view source” of the page. Please verify that I have created an element correctly.

    Customer Support

    Hi Anjan,

    Can you try disabling caching/optimization plugins temporarily and test again if it’s working?


    Hi Fernando,
    Thank you for quick reply.I don’t have any caching plugin enabled. I have “Rank Math SEO PRO” plugin enabled. Should I disable it? When I will disable the Rank Math SEO plugin, settings of plugin would be saved, right?

    Customer Support

    I see. Yes, settings should be saved in the database.

    Can you try reaching out to Windows Live Writer support as well? They might have an insight regarding the issue: https://social.microsoft.com/Forums/en-US/home?forum=writergeneral

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.