[Resolved] Blog – “read more” button displays only on the first blog post

Home Forums Support Blog – “read more” button displays only on the first blog post

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1402106
    Jana

    Hi there,

    I have three blog posts on my blog site, but only the first blog post displays the “read mor” button. The other two posts don’t display this button and neither the excerpt. They only allow to click on the post title which leads to the whole article.

    In the customizer in layout>blog “display read more as button” is activated. “Content type: excerpt” is also activated. This all works but only on the first post.

    Can you let me know what the issue is?

    Thanks!

    Jana

    #1402392
    David
    Staff
    Customer Support

    Hi there,

    can you link to your site so i can see the issue.
    You can edit your original topic and add the link to the Site URL field.

    #1402421
    Jana

    Hi David,

    done… but I haven’t published the site yet, so not sure you can see that?

    Thanks,

    Jana

    #1402465
    David
    Staff
    Customer Support

    Yeah – i would need to see a published site.
    Can you check that the Post Format in the post editor is set to Standard on those posts missing an excerpt.

    #1402472
    Jana

    Alright, in case I won’t find a solution I’ll let you know when the page is live so you can check.

    Yes, all posts are standard. The automatic excerpt and read more button only shows on the first post. On the other two there is none. I can add a manual excerpt, so this would be a workaround, but it still doesn’t solve the issue of the read more button not displaying. Strange.

    #1402494
    David
    Staff
    Customer Support

    Were those posts imported from another site on a different theme?
    Either way you may want to try creating a new post and copying the content into it.

    If not let us know when the site can be viewed.

    #1405712
    Jana

    Hi David,

    reading your last post I got the idea of simply duplicating the post where it worked and editing it to see if it behaves the same. And yes, it worked!

    Am still unsure what the issue was as the settings seemed to be 100% the same, but never mind – by duplicating and editing I solved the issue.

    Thanks a lot!

    #1405965
    David
    Staff
    Customer Support

    Sometimes the post meta options has a funny turn 🙂 Which theres no reasonable explanation for.
    Glad to hear its resolved.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.