Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Blog posts not showing in mobile view

Home Forums Support Blog posts not showing in mobile view

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #214191
    mywonder

    Hi Tom,

    I want my blog posts to be what shows up when people go to my site. I have a tutorial on setting up a blog and always thought this was the way to do it. I know it’s the way I set up the blog with my sandbox site, but I was also using a different theme when I set it up, before I found GP. I’m now setting up my production site, but some of the settings mentioned in the tutorial aren’t available when I create a page. There is nowhere to drop down for Page Template and choose Blog (per tutorial below). Is that a GP thing? Does GP not support Page Template function?

    I worked on a work around last night and what I did seems to work for the desk-top view, but not the mobile view. In Settings>Reading, I have front page set to display latest blog posts. I created a page for the blog called Podcast and then in the menu, I put the url for the site as the custom link for Podcast. It seems to work really well–on desk-top (the sample blog posts I made show up under Podcast menu item). The posts do show up on mobile, but only if I click on my logo to bring me back to the main page. In mobile, if I click on the menu item Podcast, the episodes are not there. I am not using the GP blog add-on, if that is part of the issue.

    Here’s the tutorial I am wondering if does not work with GP:
    “Create a new page, named Blog (or whatever you’d like to name it).
    Leave the body of this page blank (don’t add any text).
    In Page Attributes, in the dropdown for Page Template, choose Blog.
    Publish the page.
    Navigate to Settings _ Reading.
    In the drop-down menu for Posts Page, choose the new blank page you just created. Save changes. Now, if you navigate to that page, you should see your blog posts in order, newest first.
    Now you can add that page to your menu so you’ll have a page for blog posts.”

    Thanks, Tom!

    #214199
    mywonder

    One untruth above, I DO have blog add-on activated, if that makes a difference. I guess I didn’t realize I was using it, because I don’t THINK I changed any settings in it. Could be wrong about that, too. 🙂

    #214223
    Tom
    Lead Developer
    Lead Developer

    It sounds like you’re reading a tutorial specific to a theme that has a Blog template, which isn’t standard WordPress practice.

    If you want your home page to be your blog (latest posts), then the option you set in “Settings > Reading” is the way to do it.

    Not sure what’s going on with your Podcast menu item – is it linking to the home page? Or a separate page? If it’s linking to a separate page, what’s telling that page to show posts?

    If Podcasts is a category in the blog, you’ll want to add it to your menu using the “Categories” module on the left in “Appearance > Menus”.

    #214346
    mywonder

    Because of my other problem, I uninstalled WP completely and then resinstalled WP, resinstalled GP and the plug-ins, set up my menu again, and now I can see the posts in the Customizer when in mobile 🙂

    So, hopefully resolved and THANK YOU!

    #214375
    Tom
    Lead Developer
    Lead Developer
Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.