[Resolved] Blog images not showing in Blog Post page

Home Forums Support Blog images not showing in Blog Post page

Viewing 15 posts - 1 through 15 (of 35 total)
  • Author
    Posts
  • #359540
    Kin Kok

    Hi, I noticed that the images in my blog posts do not show up in the blog post page. It only showed up when the settings is for full posts rather than excerpts. I checked your forum and noticed this was an issue since 2014. Tom said the issue would be fixed. I just got GP premium 1.3.1 less than two months ago. I thought the issue should have been fixed by now. Did I get an old version of GP Premium? Has my version of WordPress got anything to do with it? I noticed that there is GP 1.3.48. Is this the latest version.

    #359560
    Tom
    Lead Developer
    Lead Developer
    #359705
    Kin Kok

    Ok, I see where the problem is now. I uploaded the image into the text editor.

    #359739
    Tom
    Lead Developer
    Lead Developer

    Ah yea – for images to show with blog excerpts, they must be set as a featured image.

    #359892
    Kin Kok

    Could you help me with a minor issue? Options for text alignment with the featured images are available only for the blog page. How do I do a text alignment, say left align, for a blog post with its featured image?

    #359910
    Leo
    Staff
    Customer Support

    Hi there,

    Not quite sure what you mean? The featured image should be left align by default.

    Can you provide a link to the post in question?

    Thanks!

    #360100
    Kin Kok

    The website is not up yet. It is under “Coming Soon” maintenance mode. (I use Elementor for this feature.) I am a little reluctant to bring it out of that mode. Are you able to provide me an email address so that I can send a screenshot to you instead?

    Let me try to explain again the issue. I create a post (say, ABC) with a featured image. The featured image sits at the top with the text below it. When I go to the page that was set as Posts page (say, NEWS) under settings>readings, the text was left aligned with the image. What I would like is to have the text in ABC (post) to be left aligned as in NEWS.

    #360173
    Leo
    Staff
    Customer Support

    You can upload the screenshot to a site like this: https://postimages.org/

    Then just copy and paste the direct link here.

    A link to your site would definitely be more helpful though and you can send it through Account Issue if you want to keep it private: https://generatepress.com/contact/

    #360289
    Kin Kok

    I have sent a link to my site through to https://wordpress.com/contact/

    #360308
    Kin Kok

    In case the link I sent does not take you to the page, here’s the link for the image https://postimg.org/image/q2jfblbvf/

    #360311
    Leo
    Staff
    Customer Support

    The page you sent is under maintenance mode. Can you disable it?

    The screenshot looks quite normal to me though?

    #360542
    Kin Kok

    I think you did not understand the issue that I raised about text alignment with featured image. Did you read through the previous posts that I made?

    The screen shot is to show that the featured is set at the top while the text is below the image. Is this supposed to be normal? In other words, is the featured image will always be at the top with the text below it?

    #360573
    Leo
    Staff
    Customer Support

    Yes I did. It is normal if that’s the setting you are using.

    You can change the setting in Customizer > Layout > Page header > Single Post Header Location.

    #360725
    Kin Kok

    My original setting for the Single Post Header Location was Inside Content Area. I tried all the other settings. None of them work. The featured image remained stubbornly above the text.

    #360727
    Leo
    Staff
    Customer Support

    I’ll need to see your site but it’s still under maintenance in the link you sent.

Viewing 15 posts - 1 through 15 (of 35 total)
  • You must be logged in to reply to this topic.