[Resolved] blog feed url displays in rss feed readers

Home Forums Support blog feed url displays in rss feed readers

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1144345
    David

    Hi there,

    The feed url of my blog is showing up at the top of each post, when reviewed in a feed reader e.g.- feedly.

    This has only occurred after installing the Generatepress theme. This has occurred for all 4 posts using this theme.

    could you advise hot to stop this from occurring as I cannot find an option that would switch this on or off.

    Any advice greatly appreciated; the url is https://darkstories.com.au/feed/

    Kind Regards
    David

    #1144844
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That’s strange, I’m not seeing anything in the HTML that would cause that.

    Can you turn on excerpts for now instead of showing the full content in Customize > Layout > Blog? I’d like to check out the HTML for excerpts specifically.

    Let me know 🙂

    #1144973
    David

    Hi Tom, thanks for your reply. I’ve turned on excerpts now.

    Kind Regards
    David

    #1145118
    Tom
    Lead Developer
    Lead Developer

    I’m still seeing the full posts on yoursite.com/blog.

    Are you setting the excerpts manually in the post by chance? If not, do you have any custom functions added to the site?

    The theme itself shouldn’t be doing this. You can see there is no URL in the description fields here: https://generatepress.com/feed

    #1146460
    David

    Hi Tom,

    Are you setting the excerpts manually in the post by chance?
    No; it has been updated via the Customize > Layout > Blog option. I hate to say it, but it may be necessary to clear your cache. I can see that the blog page is showing as an excerpt from here; I am testing a CDN in the last few days which may be taking some time to update too.

    If not, do you have any custom functions added to the site?
    No. Although I have made switched off a plugin that may have had an impact. I’ll be releasing another article at the end of the week, so am happy to see what happens then.

    But, yeah – otherwise it is a perplexing mystery.

    Regards
    David

    #1147367
    Tom
    Lead Developer
    Lead Developer

    Can you try adding a test post without Site Origin builder? Just plain text.

    Let me know 🙂

    #1418624
    David

    Hi Tom,

    My apologies for the extremely delayed responded; I only just revisited this issue now, and have been able to resolve the issue.

    For future reference, if it should ever occur again in future to anyone else.

    The issue was related to the Yoast SEO Plugin. In the “Search Appearance – Yoast SEO” tab; under the “RSS feed settings”, there is an option “Content to put before each post in the feed”, which I had populated with “https://darkstories.com.au/feed/” for some reason.

    Once removed, the problem went away.

    Best Regards
    David

    #1419254
    Tom
    Lead Developer
    Lead Developer

    Glad you resolved it! Thanks for reporting back, we appreciate it 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.