[Resolved] Blog – Disable Excerpts

Home Forums Support Blog – Disable Excerpts

  • This topic has 5 replies, 2 voices, and was last updated 3 years ago by Leo.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #403188
    Sean

    I’m trying to disable the excepts completely from search pages, and the index. My plan is to just have each post’s metadata show(title, date, category, tags). Or if possible, show the Page Header for that post. I don’t think it’s possible to have more than 1 page header per page, so the more likely solution would be disabling the excerpts completely. I tried setting it to zero using GeneratePress in the Customize tool, and deleted the “read more” text, but it still shows the … 3 dots and takes up that line.

    GP Premium 1.4.3
    #403274
    Leo
    Staff
    Customer Support

    Hi there,

    Try this CSS:

    .entry-summary {
        display: none;
    }

    Adding CSS: https://docs.generatepress.com/article/adding-css/

    #403278
    Sean

    That will do it, almost had to resort to downloading a separate plugin. Thank you for the save 🙂

    #403282
    Leo
    Staff
    Customer Support

    This is actually fixed in the next version as well which gives you many more options in blog.

    Feel free to take a look and test out the beta: https://generatepress.com/gp-premium-1-5-alphabeta/

    #403293
    Sean

    I’m afraid to try the beta, and then something becomes broken, and then I gotta start over sort of thing. Or is it not like that?

    Edit: I took the risk. There’s only one issue with disabling except in the customization menu, there’s still something causing a gap. I’m not entirely sure how to explain it. Using the code you provided previously tightens it up again.

    #403348
    Leo
    Staff
    Customer Support

    Ok we will take a look.

    The code way should still work well 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.