[Resolved] Blog Archive excerpt setting not being applied consistently

Home Forums Support Blog Archive excerpt setting not being applied consistently

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1381144
    Curt

    New site. Just added dummy content and set the homepage to display posts.

    I open Customize > Layout > Blog and under Content > Archives I set the Content Type = Excerpt, Excerpt Word Count = 22.

    But those settings are only being applied to some of the five entries on that homepage. The rest are full text.

    Images are also not responding to some settings. In that same interface location I set Featured Images > Archives to align Right. But they’re still centered. I can resize those images just fine. But the alignment isn’t working.

    I’m using a basic child theme and the functions.php is empty. There’s also no additional CSS that might cross the selector streams.

    #1381153
    Leo
    Staff
    Customer Support

    Hi there,

    Are the excerpt metabox empty for those posts that aren’t working?

    For example, the excerpt of this post:
    https://www.screencast.com/t/ibSUC3gJ

    Doesn’t match the actual content:
    https://www.screencast.com/t/if3hHayz8Rfi

    #1381164
    Curt

    Using the classic editor, and I don’t have anything installed to set the excerpt except the
    <!–more–> tag. So yes, I’m not specifying any excerpt in the Post admin interface.

    That occurred to me but I thought there would be some kind of default definition of excerpt length.

    #1381177
    Leo
    Staff
    Customer Support
    #1381185
    Curt

    I referenced that exact same article, and installed the snippet. But that only adds to Pages and not Posts. So still at square one there.

    I also have Yoast on other sites that I can add here and activate. I think it can add the excerpt at the post level.

    I guess the lesson here is that the excerpt and excerpt length settings in GP both require you have an excerpt defined?

    #1381209
    Curt

    Oh Jesus H.

    Was adding that excerpt field on Posts really as easy as just going into Screen Options and checking a box? Noob of the year. Right here, Leo.

    #1381339
    Leo
    Staff
    Customer Support

    Glad you’ve figured out 🙂

    #1382120
    Curt

    I can’t quite close this out yet because I’m still seeing erratic behavior with both the excerpt (some showing properly, some full text) and image alignment (all centered even though set to align right). Both of those are properly set in the Customize settings.

    I’m going to flush that dummy content and start new in case that’s part of the issue.

    #1382128
    Leo
    Staff
    Customer Support

    Sounds good.

    Just reply here again when we can look at the issue.

    #1382181
    Curt

    Yeah, put new dummy Posts in there and …

    1. Image alignment still centered, but specified Right.

    2. Excerpt still not performing as expected. Length set at 22 but it appears to be showing whatever is set in the Excerpts field in post meta.

    3. No Read More button appears as specified, except on the first article.

    #1382185
    Leo
    Staff
    Customer Support

    Let’s take care of the excerpt issues in this post and please open a new topic for the image questions.

    2. That is the whole point of the excerpt field/metabox. When that field is used, it overwrites the default excerpt word count. It should make sense since the excerpt in the metabox doesn’t actually show in the post content so there is no point to add it in if it just gets trim by the word count.

    3. This should help:
    https://docs.generatepress.com/article/activating-read-custom-excerpt/

    #1382218
    Curt

    Got it. Removed all text from excerpt fields and it’s now behaving as expected. Thanks for the explainer.

    Image thread coming soon.

    #1382245
    Leo
    Staff
    Customer Support
Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.