[Support request] Block Element Type box missing from sidebar

Home Forums Support [Support request] Block Element Type box missing from sidebar

Home Forums Support Block Element Type box missing from sidebar

  • This topic has 25 replies, 4 voices, and was last updated 1 month ago by Elvin.
Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #1930743
    Rosina

    I watched the videos on how to add a post meta block, checked to make sure everything was installed, and then ran into a wall. I’m attaching two screenshots. The first is from the GP video on how to do this, and the second is from my screen.

    You’ll see that my right hand sidebar does not look like the right hand sidebar in the video. After clearing caches, etc etc, the problem persists.

    At this point I’m wondering about two possible points where this is breaking down:

    1. I own a copy of GeneratePress, but am using the free version of GenerateBlocks. Is it not possible to create a custom meta box without the GenerateBlocks Pro version?

    2. I have two GP plugins activated (GP Pro, GP Blocks). Am I missing one called GP Dynamic Content ?

    I am really looking forward to being able to create a custom post meta box, but at this point I’m pretty confused. Any direction would be much appreciated.

    The site I’m building isn’t live yet and definitely not ready for prime time, but in case this will help: sara donati fiction

    #1930744
    Rosina

    Of course I forgot the screenshots. from the how-to video
    what my screen looks like (missing elements)

    #1930746
    Leo
    Staff
    Customer Support

    Hi there,

    Do you have the Classic editor plugin activated?

    If so you will need to deactivate it to use the block element.

    Let me know if this helps πŸ™‚

    #1930747
    Rosina

    I do have the classic editor plugin activated. I’ll turn it off and see what happens. And let you know. Thanks for the quick response.

    #1930764
    Leo
    Staff
    Customer Support

    Sounds good. It should work πŸ™‚

    #1930765
    Rosina

    Yes, it is working. Now if I could just get the bits into the meta box…

    #1930767
    Leo
    Staff
    Customer Support

    Now if I could just get the bits into the meta box…

    Sorry can you explain a bit more?

    #1930772
    Rosina

    Yes, I can explain.

    I’m in the generate block pages. Trying to put together a post meta box for a custom page type (wiki article). Attaching link to what I’m trying to achieve.

    It’s very difficult to add elements to the container when you have a combination of text and elements. For some reason adding categories seems to work, but adding tags does not. And I can’t get the box to show up on any wiki pages at all. I am wondering if there might be more meta box templates somewhere.

    mockup of meta box for wiki articles

    #1931751
    Leo
    Staff
    Customer Support

    Hmm you should be able to create that metabox with dynamic properties no problem.

    Can you take a look at this article to make sure you are doing everything correctly?
    https://docs.generatepress.com/article/dynamic-data/

    Here is a video that might help as well:

    #1933207
    Rosina

    I was able to create the post meta element (I think) and to set it to appear only on wiki pages, but it’s not showing up and I’m not sure why. Here is a screenshot of the element screen.

    This wiki page is one where the post meta box should be showing up.

    Any thoughts?

    #1933349
    Elvin
    Staff
    Customer Support

    Hi Rosina,

    I’m not sure if that display rule location is for wiki static pages or for “Wiki” post type.

    The link you’ve provided seems to be a post type but the display rule seems to be pointing to static pages.

    Any chance you can let us have temporary back end access to understand the CPT and taxonomy relationships on your site?

    You can use the private information text field to provide the details. πŸ˜€

    A wise man once said:
    "Have you cleared your cache?"

    #1933431
    Rosina

    I’ve set up a temporary admin account for you, see below.

    #1933947
    Ying
    Staff
    Customer Support

    Hi Rosina,

    Can you share the WP login link as well?

    It seems /admin and /wp-admin both don’t work.

    Let me know πŸ™‚

    #1934015
    Rosina

    Our power is out. I will reply ASAP.

    #1934313
    Rosina

    This is complicated, so let me take it step by step.

    When I installed and activated the GP theme, there were security guidelines on the dashboard. One of them was the importance of changing the log-in url. I followed the directions and changed the login url to “https://saradonati.com/wiki/morestuff.php” . It struck me as odd that this would end up as a php file. Now just a few days ago I realized that if I went to that url, I got a 404 page. I also tried accessing through the standard /admin and /wp-admin urls, and again I got 404 errors.

    to fix this I tried to backtrack, but I cannot pinpoint where I saw that security suggestion.
    Since that point I continue to not be able to login in the usual manner. I have to go to my web host and log in through them, and that works fine. So I put this 404 redirect problem aside for the moment. Not the brightest move.

    Then I asked for help with the post-meta element, and supplied login information. It wasn’t until you wrote back that I realized that there isn’t a way to log-in except going through my web host user tools. So I have put out some questions on how to fix this problem, but haven’t heard anything back yet.

    Can you tell me how to reinstate a normal log-in link/page?

    If you cannot, I’ll hope to get some help elsewhere. As soon as this issue is resolved I’ll send you the url for logging in.

    Sorry for the long explanation.

Viewing 15 posts - 1 through 15 (of 26 total)
  • You must be logged in to reply to this topic.