[Resolved] Block Element Error

Home Forums Support [Resolved] Block Element Error

Home Forums Support Block Element Error

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
  • #2587854

    When I try and create a new block and select the Hook Name, I keep getting the following error message:

    “The “generatepress-block-element” plugin has encountered an error and cannot be rendered.”

    I tried deactivating all plugins except GP premium and Genreateblocks but I still keep getting the error.

    Customer Support

    Hi Daniel,

    That sounds very strange. Generatepress block element isn’t a plugin.

    The temp login link provided also requires a username and login so I wasn’t able to check.

    Can you confirm?

    Thanks 🙂


    Hey Leo,

    I’m sorry. I meant that I deactivated all the plugins except the GenerateBlocks & GP Premium Plugins and I still got this error.

    I have added the updated login info.


    Customer Support

    Hi Daniel,

    I tried logging in but it says that the password is incorrect.


    Hey Fernando.

    Sorry about that! I added the correct credentials.


    I also encountered the same problem, I added a block to insert the footer, I upgraded wp6.2, I don’t know if it is the reason of this month.

    【The “generatepress-block-element” plugin has encountered an error and cannot be rendered.】

    Actually it works if you force save.


    I have encountered this too on two sites when creating a Block Element and then using the Block Element dropdown.

    Both sites are updated to WordPress 6.2. All plugins are up to date and GP is also up to date.

    The error message only occurs when choosing the Hook Element Type and then the Hook Name.

    If you ignore the error message and save, you then lose all the active fields under the Element tab. But if you then leave the page and open it again from the Admin Element list you see that your work has been saved and the hook works.

    The error occurs again if you alter the Hook Name

    Customer Support

    Hi there,

    we will do some tests, as this sounds like a bug with 6.2. And we will update the thread asap.


    Thanks David.


    I get the same error when choosing a hook.

    Lead Developer
    Lead Developer

    We just released GP Premium 2.3.1 which fixes this issue.

    Thanks for letting us know! 🙂


    Hi Tom

    Brilliant. Just downloaded and checked… all good!

    Thank you for sorting this so quickly 🙂

    Lead Developer
    Lead Developer

    Awesome, thanks for letting me know! 🙂

    melvin wang



    I encountered this error. Quick forum search… you are on it, you have it fixed and my problem was solved about 3mins after it occurred. Having such a professional team behind the products I use daily makes such a difference. I am super grateful, thanks for being so good at what you do – it makes a massive difference.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.