Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Support request] Bizarre – Comments Box on Every Page!

Home Forums Support Bizarre – Comments Box on Every Page!

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #368027
    Antar

    Hello, All –

    I’ve never encountered this before, but as the title says, a comment box has mysteriously appeared on every page on the site. Before you ask, comments are disabled site-wide. I’ve even tried using a small script in the functions.php to get rid – but event that doesn’t work!

    The only thing I’ve been able to do is create a new (alternative) page template from which I have removed the following code:

    <?php
      // If comments are open or we have at least one comment, load up the comment template
        if ( comments_open() || '0' != get_comments_number() ) : ?>
          <div class="comments-area">
            <?php comments_template(); ?>
          </div>
    <?php endif; ?>

    I have no idea what is activating this code when all the settings are switched off?!

    :0(

    Antar

    GP Premium 1.4.2
    #368093
    Leo
    Staff
    Customer Support

    Hi there,

    Can you provide a link to your page in question? Thanks!

    #368108
    Antar

    Hi, Leo –

    Thanks for the help. Can I PM you?

    Antar

    #368126
    Leo
    Staff
    Customer Support

    Yup send it through Account Issue: https://generatepress.com/contact/

    Please reference this topic.

    Thanks!

    #368133
    Antar

    OK. Done.

    For the record, I have a few commercial plugins installed including:

    Elementor
    GP Extender
    MailPoet
    and several of the more popular tools from WPMUDev

    I’ve tried deactivating several of them but nothing seems to work!

    Antar

    #368137
    Leo
    Staff
    Customer Support

    Just making sure you are referring to the Leave A Comment area at the bottom of the page?

    The settings in Settings > Discussion only applies to new posts.

    For existing posts, you need to go to Dashboard > Posts > Hover the title > Quick Edit then uncheck allow comment.

    Let me know if this helps.

    #368145
    Antar

    None of the existing posts have “Allow Comments” activated.

    #368165
    Leo
    Staff
    Customer Support
    #368172
    Antar

    Hi Leo –

    Thanks for this. It still seems bizarre. Presumably this setting is not “on” by default?

    #368174
    Leo
    Staff
    Customer Support

    It is On by default.

    You can turn it off in Settings > Discussion but that will only apply to new posts, not existing posts.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.