[Support request] Anomalies with Header as Navigation

Home Forums Support Anomalies with Header as Navigation

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1677193
    pairfum

    Dear Support,

    We have just switched to use ‘header as navigation’ per these instructions:
    https://docs.generatepress.com/article/navigation-as-a-header/

    We now find the following anomalies on our website:
    https://www.pairfum.com

    1. Multicurrency Switcher

    A) The drop-down for the multi-currency switcher only appears when we scroll down. When the page is at the very top, the drop down does not appear.

    B) When the user hovers just below/above the currency symbol in the navigation menu, the colour does not change. The background colour changes but the currency symbol. The currency symbol only changes when the mouse is exactly on top the currency.

    2. Jumpy Navigation Bar

    We notice that the menu is bit jumpy on the initial scroll. Is there a reason for this?

    Is there something that can be done to make it calmer?

    Many thanks for your help.

    Kind regards,

    Pairfum London

    #1677544
    David
    Staff
    Customer Support

    Hi there,

    i cannot see the currency switcher in the navigation – has that been disabled?

    Ill take a look at the #2

    #1677628
    pairfum

    Hi David,

    This might be caching that prevented you from seeing the currency switcher. I have cleared the Website & Cloudflare cache and you should now be able to see it.

    When we switched to the ‘header as navigation’ I noticed that the currency symbol / abbreviation had taken on the same colour as the background but since changed this white.

    Kind regards,

    Pairfum London

    #1677691
    Leo
    Staff
    Customer Support

    This might be something you need to check with the plugin’s support team.

    Does the issue happen when you use a parent theme?

    #1677718
    pairfum

    Hi Leo,

    Many thanks for your reply.

    We did not have this issue before we switched to ‘use header as navigation’, i.e. this is clearly linked to GeneratePress and not the plugin itself.

    The anomalies disappear as soon as we de-activate the option ‘use header as navigation’.

    If you find it helpful, I can create a staging site which uses ‘header as navigation’ and deactivate this option on the live site, i.e. switch it back to what it was beforehand.

    Let me know how you would like to proceed.

    Kind regards,

    Huib

    #1677725
    Leo
    Staff
    Customer Support

    If you find it helpful, I can create a staging site which uses ‘header as navigation’ and deactivate this option on the live site, i.e. switch it back to what it was beforehand.

    That sounds good. Make sure you disable all plugins and use the parent theme.

    #1678448
    pairfum

    Hi Leo,

    As agreed, here are now the two versions of navigation:

    1. original/normal navigation

    This is visible on our live site: https://www.pairfum.com

    You can see here that the multi-currency switcher is working perfectly.

    2. ‘header as navigation’:

    This is working on our staging site: https://staging.pairfum.com

    On the staging site, the same plugins are currently active as on the live site.

    On the staging site you can see the anomalies that I describe above.

    I have also just noticed another anomaly on both the live and the staging site:
    On our main blog landing page, the mobile navigation menu does not stick to the top when scrolling down. When scrolling in the opposite direction, i.e. scrolling up, only the ‘cart’ icon is visible.

    This is the page I am referring to: https://www.pairfum.com/blog/

    What is surprising is that this anomaly only happens on this page and not on any other page, post or product.

    This blog page is built using the BeaverBuilder Plugin, as are most other pages (but not posts and products), which is why it is surprising that this happens only on this particular page.

    It would be great, if you could investigate this anomaly as well.

    Many thanks for your help with this.

    Kind regards,

    Pairfum London

    #1679197
    Leo
    Staff
    Customer Support

    On your staging site, have you disabled all plugins except GP Premium and currency switcher plugin and then activate the parent theme?

    #1681569
    pairfum

    Hi Leon,

    On the staging site (https://staging.pairfum.com), we have now disabled all plugins apart from:
    – Beaver Builder Plugin
    – GP Premium
    – Shortcodes in Menus: https://en-gb.wordpress.org/plugins/shortcode-in-menus/
    – WooCommerce
    – WooCommerce Multi Currency Premium: https://villatheme.com/extensions/woo-multi-currency/

    The GP parent theme is active, i.e. NOT the child theme.

    What I now notice is the following:

    1. Multicurrency Switcher

    This is still as described above, i.e. when I raised the ticket.

    2. Jumpy Navigation Bar

    This is still as described above, i.e. when I raised the ticket.

    3. Navigation Bar Anomalie on the Blog Page

    This issue is now gone. In other words, it must be a conflict with another plugin that causes this problem and we will investigate this ourselves.

    I would now very much appreciate your support to fix issues 1 & 2, as they seem to be linked to the Theme.

    Many thanks for your help.

    Kind regards,

    Pairfum London

    #1682371
    Ying
    Staff
    Customer Support

    For issue 1 and 2, try this CSS:

    #site-navigation {
        position: sticky;
        top: 0;
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.