[Resolved] AMP Compatible CTA widgets or modules on GeneratePress 2.4.1 (Premium User)

Home Forums Support AMP Compatible CTA widgets or modules on GeneratePress 2.4.1 (Premium User)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1176944
    Kevin

    I’m currently using AMP framework with GeneratePress theme. So far, the theme is working great and is compatible with what we are trying to do.

    One thing I’m noticing is the limitations with using modules/widgets for CTA (call to action) like a floating phone icon linked to my business or a form sidebar for my visitors to fill out. I wanted to see if there are any AMP-compatible Call to Action widgets/modules/plugins I can use on my site and remain AMP-compatible or a page I can be directed to with further details on best practices for GeneratePress themes?

    I’m currently testing in a staging environment but you can see a version of my site here:

    https://recipes.crockthepot.com/

    I appreciate your help.

    Kevin

    #1177752
    Tom
    Lead Developer
    Lead Developer

    Hi Kevin,

    As long as something doesn’t use javascript, it should be AMP-compatible. Most call-to-actions shouldn’t use javascript.. Forms might if they use AJAX to submit, so you might need to use non-AJAX forms.

    Let me know if you need more info 🙂

    #1202128
    Kevin

    Thanks!

    #1206176
    Tom
    Lead Developer
    Lead Developer
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.