[Support request] Add to Menu in Customizer not working

Home Forums Support [Support request] Add to Menu in Customizer not working

Home Forums Support Add to Menu in Customizer not working

  • This topic has 31 replies, 5 voices, and was last updated 5 years ago by Tom.
Viewing 15 posts - 1 through 15 (of 32 total)
  • Author
    Posts
  • #230456
    Dave

    New installation… When I try to add a page or custom link in the customizer menu and click the “Save/Publish” button the changes to not save. I can add pages in the regular WP interface and then manipulate them in customerizer after they are created.

    I have read posts about increasing memory allocation to 128 MB and I have done that, but this is not fixing the issue. Any suggestions would be helpful.

    #230506
    Tom
    Lead Developer
    Lead Developer

    Hmm, I would assume PHP memory issue.

    If it’s that not, and it’s happening with no plugins installed, then it has to be something going on in your server configuration. Have you found any hints by Googling it?

    #230560
    Dave

    Yes i have Googled this issue and it has brought me to these forums. I have also found info on issues with other plug-ins, but not any plug-ins I have running. I’ve disabled plugins Akismet, Contact 7, Jetpack, and Wp Super Cache without better results trying to save menu items in customizer. Additionally i have another site running GP Premium on the same server with those same plugins (and more] running without this issue therfore I’m feeling like server configuration is not the issue. That said, what particular server configuration are you referring to? At this point I’ll try anything.

    #230606
    Roberto Enrique

    I’ve been through a similar situation some months ago.
    In my case was something related with the Timeout for the scripts in the server.
    Using the developer tools in your browser look at your console and/or network panel and see if there are errors.
    In my case there were some issues with admin-ajax.php

    #230703
    Dave

    Thank you for the info to look a the web tool. Interesting… When I am using customizer to “Save and Publish” a change in the menu I see 404 errors on calls to /wp-admin/admin-ajax.php, but only when customizer calls the file in the “Menu” section. Other sections of customerizer call the file without the error.

    I can confirm that admin-ajax.php does exist in the wp-admin directory (Below is the error and I have removed the domain name and replace it with <domain> in this sample. Are there any thoughts on how the “menu” part of customer can be broken, but not other parts?

    load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:4 POST http://www.<domain>.com/wp-admin/admin-ajax.php 404 (Not Found)send @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:4ajax @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:4(anonymous function) @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:84a.Deferred @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:9send @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:84post @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:84f @ load-scripts.php?c=1&load[]=customize-base,wp-a11y,customize-controls,customize-widgets,jquery-ui-s…:4save @ load-scripts.php?c=1&load[]=customize-base,wp-a11y,customize-controls,customize-widgets,jquery-ui-s…:4(anonymous function) @ load-scripts.php?c=1&load[]=customize-base,wp-a11y,customize-controls,customize-widgets,jquery-ui-s…:4dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:3r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,underscore,jquery-ui-widget,j…:3

    #230706
    Roberto Enrique

    You should contact your hosting company

    #230713
    Dave

    I should have mentioned that I contacted the hosting company first and they blamed WP/GP. It’s the circle of life 😉

    Thank you for your time… I do appreciate the responses. Hopefully when I go back to the host and tell them I get intermittent 404’s on a file they actually do something to look at it. Thanks again.

    #230720
    Tom
    Lead Developer
    Lead Developer

    Hosting companies like doing that.

    Hmm, 404s.. Maybe your .htaccess file is corrupted? Worth deleting it and then going to “Settings > Permalinks” and re-saving your permalinks.

    Still not working.. Maybe re-install the WordPress files in “Dashboard > Updates”.

    #230791
    Dave

    Well.. I’ve tried all the options mentioned in this thread and even options mentioned by the web host. Resetting permalinks.. no joy. htaccess review … no joy. I’m convinced this is something to do with the latest version of WP and GP.

    After nothing worked to alleviate the 404 on /wp-admin/admin-ajax.php when using the customizer menu update of GP I deleted my site and did a fresh install of WP.

    Installing nothing else I installed GP free theme. My menu is not broken at this point in that I can save any changes I make. Then I activate my GP Premium. As soon as I did that, when I use customizer I get 404 errors on /wp-admin/admin-ajax.php on menu manipulations and then trying to save….but again.. only when using the customizer menu functions.

    To me, this would indicate some issue with the GP plugin and admin section of WP. Seems like I find tons of info when searching “404 on wp-admin/admin-ajax.php” as related to random admin section 404 errors on this file. Some issues reported it was a plugin issue and some reported re-saving permalinks setting fixed it.

    I’m not sure really if this is a WP 4.6.1 problem, a GP problem, or a combination of both. There really isn’t more I can do as I’m new to WP, but I think something is wrong with this version of WP and GP. Hopefully more skilled folks than I can duplicate this issue and come up with a fix or explanation as to why this is happening.

    #230793
    Tom
    Lead Developer
    Lead Developer

    If it were directly related to GP Premium, there would be quite a few people in here mentioning the same thing.

    You also mentioned this above:

    Additionally i have another site running GP Premium on the same server with those same plugins (and more] running without this issue therfore I’m feeling like server configuration is not the issue.

    Which also indicates it’s not a GP Premium issue.

    It seems others have encountered the same thing. While hosting companies like to say nothing is wrong, I’m willing to bet that it’s server related.

    For example: https://wordpress.org/support/topic/admin-ajaxphp-404-not-found/

    Just so I don’t seem like I’m brushing you off, I have tried to replicate this myself using WP 4.6.1 and WP 4.7 (beta) with no issues.

    Do you have another server you can test on? Even a local server using XAMPP or WAMP? If you can narrow it down to your server and they’re still not willing to help or look further into it, then finding different hosting might actually be beneficial to you.

    The file exists (admin-ajax.php) yet it’s returning a 404 error (not found). That screams server to me.

    Let me know 🙂

    #230805
    Dave

    Thank you for taking your time. Never thought for a second that I was getting brushed off. Ironically between my first post and now my other site auto-updated. I have just checked my other site after the WP upgrade and it too now is “broken” when trying to use the customizer menu.

    No one else is complaining… maybe I’m the first 🙂 Since you are not able to replicate, that points me back to the host.. I agree with that so I will work further to eliminate GP. Still have a hard time with the fact that you can go right to the URL of http://www.<domain&gt;.com/wp-admin/admin-ajax.php and get the response, but when called from a specific plugin call you get a 404. Rhetorical question, but how can that be? How can a web server decide to respond 200 for a URL typed in a browser address bar and 404 for the same URL when called from software?

    I did try the ideas in the thread you quoted… no joy there as well.

    Maybe it is server related, I would not discount that either…. but what exactly about the server do we feel could cause such an anomaly? My host tells me it is the software (WP or GP) because you can go to the URL directly and not get a 404. The software tells me it’s the server because it isn’t broken elsewhere. It’s an enigma wrapped up in a conundrum 🙂

    I’m not giving up… will keep trying on a local install on my PC to see what happens. Thanks again.

    #230811
    Lyle

    Thought I would jump in here as I have never tried to add a menu item that way … didn’t even know one could do so 🙂 Cool!

    That said, I have just now tried doing so with the latest of everything, WP, GP, GP Premium (everything enabled) and running on both a Linux shared host as well as locally with XAMPP. No problems on either. Heck, I could even add a Lifter LMS Course on the live site 🙂

    Would be interesting to find out what’s going on. One thing though, I noticed you had WP Super Cache; did you flush it before deactivating it? I don’t have any experience with that one, but on one site I was doing (trying to) some updated on, WP Rocket was making me pull out what little hair I do have left! I used every “clear cache” link I could find and then deleted it; then things worked 🙂

    Cheers!
    Lyle

    http://snifflevalve.com
    Tutorials and tips for GeneratePress, WP Show Posts, WordPress and Elementor

    #230813
    Dave

    Would be interesting to find out what’s going on. One thing though, I noticed you had WP Super Cache; did you flush it before deactivating it?

    No I did not flush before deactivating. However, I didn’t install WP Super Cache when I just reinstalled on a shared Linux server (Site5) where I’m having this issue at.

    Installing XAMPP now on my PC.. will advise what my experience is.

    #230816
    Dave

    Well, I’m unable to replicate on my own XAMPP install. While a Win10 XAMPP install is not quite the same as the shared server I’m on at Site5 I am more confident of a server side issue as previously mentioned. What that issue exactly is … is and unknown to me. Any new ideas on what I can poke my host with would be helpful in regards to a server configuration. Thanks again for the time and comments.

    #230823
    Tom
    Lead Developer
    Lead Developer

    Unfortunately I don’t know exactly what the issue would be, I’m not an expert when it comes to server configurations.

    I did used to have Site5 hosting – I changed due to their lack of support at the time.

    Is the site you set up on your localhost identical? Same plugins, configurations etc..?

    Plugins like WP Super Cache are known to break things sometimes, I’m not a huge fan of caching plugins.

Viewing 15 posts - 1 through 15 (of 32 total)
  • You must be logged in to reply to this topic.