[Support request] 403 Forbidden. Your server is not able to communicate with generatepress.com

Home Forums Support [Support request] 403 Forbidden. Your server is not able to communicate with generatepress.com

Home Forums Support 403 Forbidden. Your server is not able to communicate with generatepress.com

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2057260
    Sean

    Getting this error: 403 Forbidden. Your server is not able to communicate with generatepress.com in order to activate your license key.

    #2058156
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That IP isn’t blocked on our end.

    Can you host confirm that you’re able to communicate with generatepress.com via cURL?

    If so, can you provide a traceroute so we can better see where the blockage is occuring?

    Thanks!

    #2058904
    Sean

    I have two domains where this is happening now, odd…
    Anyway, here’s their response…

    Sorry to hear about the issues you are experiencing with Generatepress on
    erxn.io. I ran a check on the domain, and I confirm that the Curl module
    is currently active within your server, in fact here is a list of all PHP
    modules that are active and operational in your domain, just for
    reference:

    erxn.io$ php -m
    [PHP Modules]
    bcmath
    bz2
    calendar
    Core
    ctype
    curl
    date
    dom
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    imagick
    imap
    intl
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Phar
    posix
    pspell
    Reflection
    session
    SimpleXML
    soap
    sockets
    sodium
    SPL
    sqlite3
    standard
    tokenizer
    xml
    xmlreader
    xmlrpc
    xmlwriter
    xsl
    Zend OPcache
    zip
    zlib

    [Zend Modules]

    I also inspected the error logs but there was no indication of an error
    with Generatepress specifically. That said, I would recommend doing a
    test by temporarily disabling Extra web security, to disable the
    modsecurity module on the server, you can do that from
    https://panel.dreamhost.com/?tree=domain.manage&current_step=Index&next_step=ShowEdithttp&dsid=44516272

    by removing the check box in Extra Web Security. Save changes and try
    doing a test after that. If it doesn’t work though, we’ll recommend
    turning the option back on, and check back with the support page of
    Generatepress, and provide them with the traceroute results that they
    asked, they may be able to investigate further with that info.

    I hope you find this information helpful, If you have any questions or
    need further assistance, feel free to reach out back to us and we’ll
    gladly assist you.

    Hopefully I provided the traceroute info as you asked in the private area. This is foreign to me.

    #2060208
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I just had our hosting check the IP and the traceroute. They’re not seeing any issues on our end.

    They did mention this:

    If they could check the logs on their provider and ask if our IP 162.159.135.42 is blocked, that could also be the case.

    If it’s returning a 403 error, there should be something logged in your error_log file on the server.

    Let us know πŸ™‚

    #2069416
    codeberry

    Hi,

    I’m receiving the same error: “403 Forbidden. Your server is not able to communicate with generatepress.com.” I checked with my web host, and they say that PHP curl is on by default.

    #2069420
    Elvin
    Staff
    Customer Support

    Hi @codeberry,

    Can you open a new topic for this? As the source of the issue for your site may be completely different from the topic starter’s. πŸ˜€

    Kindly provide the same details Tom asked so we can identify the issue faster.

    Let us know. πŸ˜€

    A wise man once said:
    "Have you cleared your cache?"

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.